RC2 Release - display log


#1

Dear all,

Is there anyway to display an active log when running the zcashd daemon? Just so I can see if it's doing something?

Been trying for days and still no coins, even ones that have been sent to me:
tmTogotT4exnUjc6NYB7FLZmpbkBaGRSWs9
via:

Soldiering on and thanks in advance,


#2

add this line to zcash.conf file:

showmetrics=1

you may also do this:

ubuntu@test:~/zcash$ ./src/zcashd -daemon -showmetrics=1


#3

where does this display? Is there a command to display it? Thank you for the help.


#4

You can also simply run in non-daemon mode (just skip the daemon flag) which will output directly to the terminal. You can use screen or similar so you can run in the background.


#5

I see, so starting the miner with ./src/zcashd -showmetrics=1 will throw up that screen...


#6

I think it defaults to it so don't even need the flag (correct me if I'm wrong as never tried it). You can disable it with =0


#7

Thanks for all of the help. It didn't default for me.

I had to stop, then start again with the flag...


#8

Is there a way to get the metrics in deamon mode.

Simmilar to this

watch -n1 /root/zcash/src/zcash-cli z_getoperationstatus


#9

I don't think there is @str4d indicated this info might be added to getmininginfo in rc3 which would be very helpful!


#10

I just let metrics run in another terminal window.


#11

Unfortunately it was left out of RC3 due to it involving too much code change. But there's an open PR you can merge into your local code if you want to use that. Otherwise it should be in 1.0.1.


#12

Awesome thanks - it's here is anyone else is interested https://github.com/zcash/zcash/pull/1642