Resoring Wallet; Lost Address?

I backed up my wallet.dat file a few months ago.

After that, I created a new address and put a little zcash in there.

Then the computer crashed and I restored from the backup.

I see all of the zcash that I had before I created the new address (basically when the backup was taken) but I don’t know how to get the new address/zcash back.

I don’t remember what the address was, just that it was a z-addy.

Any ideas?

Sorry to be the bearer of bad news, you need to perform a backup each time you create a new private address. This means that your backup is only good for the z addresses you had created at that point in time.

So if you no longer have a copy of your most recent z address and it’s private key (or the wallet.dat) then you will not be able to recover the Zcash from that address.

Hello, can I ask, what about the T addresses?

I have mined to my T address which is on a seperate ubuntu machine and I have backed up my wallet.dat and private key for that T address. I would send those to my Z address but Zcash client is updated and I will transfer those coins after I update but at the moment I can not transfer them since chain is not %100 synced ( I dont let it Sync, i got a message telling me to upgrade so I quitted). I am bit afraid of updating the client and I have to know how can I backup my T address.

Sorry if I should have created a new Topic about this, I felt like my question is also related to this one.

Thank you.

Why are you afraid of updating the client? If you want to backup (just in case) you can copy your current wallet.dat file to a USB or somewhere else then perform the update.

You can also use z_exportwallet to backup to a file for safekeeping.

Fortunately it wasn’t a whole lot of money that I lost.

However, can I make two suggestions?

1: MAKE THIS FACT CLEAR ABOUT BACKING UP WALLETS. Every otehr CC wallet does NOT work this way. You generally have a seed, and it doesn’t matter how many addresses you add. You can always recover from the initial backup.

2: Change it. :slight_smile: This is not a good system. I should be able to back up some core piece as soon as I create the wallet, and then feel confident that I am backed up.

I only lost a few hundred dollars. But it could have been so much worse.

I am sorry to hear that you have lost your ZEC, I agree that perhaps the Zcash documentation could be more explicit about the need to perform regular backup (ping @paige or @daira )

The key to remember is that if you are using a zcash4win, zcash4mac or the linux Zcash client you are running a full node on your computer, this is not any different than Bitcoin or any other coins full node software. A full Node is not a third party service that holds your money, you control all aspects of the node: its backups and security.

With third party services or hardware wallets you can try to recover your account via methods you mentioned but if for some reason you lose the hardware wallet/seed or your online account is hacked you can still lose access to your funds.

1 Like

Hm. The wallet backup documentation does mention that a new address will not be saved in a prior backup but I agree this can be more explicit. I’ll work on it.

Shawn thank you but exactly what you said is why this is confusing.

There is no seed! But the user experience is like “okay I have that primary thing backed up and everythign is generated from that” and in the case of zcash that feeling gets transferred to the wallet.

Everything you say makes sense. But when you have 20 different currencies wtih 20 different wallets your brain starts to make patterns out of them. A seed would be a big improvement.

Lucky I didn’t lose much so this is a learning experience. :slight_smile:

paige the problem with that documentation is this is the first I’ve seen it. This is the first I’ve seen the github page even. Documentation isn’t helpful if it doesn’t pop up in the process of a user experience. Like having a STOP sign facing up instead of facing the people who have to stop.

It would be good if that backup instructions page was more prominently displayed/referenced in the 1.0 guide. I am also going to post a link to it on zcashcommunity.

1 Like

Hi folks!

I*am sorry for a stupid question and my English.

I have created zcash public wallet using zcash local wallet (zcash4win). I remember my login and password, but i have losted my ***.dat file.

Can I repair/repair my local wallet? I have any dat file. only login and password

Zcash4win does not support login and password last time I checked… unless that’s a new feature @anon47418038 ?

no, and i think they mean they just have the login to their machine, and not the wallet.dat from before they nuked it from orbit, if i am reading them right

Which wallet (s) can I use to recover with my private zadder key?

Hi @KeepECC , you can use ZecWallet Fullnode or the Zcash CLI (Zcashd) full node to import private keys.

1 Like

I only have a private key and spending key my understanding is that private key and recovery seed are different are they not? I will try the full node. I was using funds to test z2z transactions and funds are now stuck, my objective is to recover these fund be using a different wallet that may sync and allow me to move those funds.

Yes, the recovery seed is different than the private keys. You can use a full node to import private keys, but you can’t import private keys with the lite or mobile wallet.

1 Like

Thank you Shawn for the clarification. I’ll post my results here for others who may run into a similar situation.

Hey Shawn,
I tried installing the zcash full node however it appears as though it only runs on x64 processor?
I run a Windows 7, Intel core 2 duo e8600@ 3.33ghz,4gb ram, 32bit OS, terabyte drives.
Is there a possible workaround?

I think I heard that you can still run a 64-bit image in a virtual environment in a 32 bit OS but I’m not sure, it’s bound to be slow but you might try running it in virtualbox with a 64-bit Ubuntu build or something
Core 2 Duo support AMD64 extension which is why you can run 64-bit windows and other 64-bit programs, interesting…
I have a 32-bit system with Windows 7 and I can never get the Zecwallet or zcashd to work

Maybe if it were running Windows 10 with Zcashd in WSL but idk ( that’s based on the same logic of the ext running 64-bit programs inside of Windows which is where WSL is located)