Rizer problem booting

Hello,

I have a h81 btc 2.0 motherboard. When I plug 1 1070 in directly to the mobo it works but when I add 1 1070 via a powered rizer I get a blue screen

It only works if inplug the rizer in the x16 slot

I would suggest trying a different riser. A lot of risers can be poor quality, so try a different one. From experience the higher the "version" of the riser, the better.

But it does work when I plug it in the x16 slot?

So if it works when you plug it into the X16 slot, and doesn't work with the riser, then logic would say it could be the riser that is causing the problem.

The riser just extends the socket allowing you to have the GPUs further away as they won't physically fit on the motherboard side by side without overheating quickly.

Ok thanks , what risers do you recommend?

I had a similar problem with an HTC btc 2.0 to 1070.

I had a 6 GPU rig running fine. Shut it down one day, rebooted and it wouldn’t come back up again. Tried over and over again. No luck. Then I started removing the boards one by one. I found that if I removed the GPU attached to the 16x slot it would work.

So I then tried pluging the other GPU’s into that slot so I could work out if it was that slot, or the GPU or the risers.

Any other GPU plugged into that slots resulted in a failed boot. But I was only moving the cables around, not removing the GPUs from their risers. So it was obviously that slot alone.

I put the GPU that had been in the 16x slot into another rig and it’s been working fine for months now.