Sending Zcash with the right transaction fee

Is there any guidelines on what the transaction fee should be when sending Zcash?
I just got a Trezor and I’m also just getting comfortable with sending transactions. so I’ve done a few test transactions. I tried sending a transaction of .0002 with a zero transaction fee and it seemed to have worked. is it possible for now to send zcash with out a fee? I did it using the zcash4win wallet if that means anything.

You can use z_sendmany and it will send with the default fee of .0001 ZEC. If you use sendmany it will adjust the fee based on inputs (this is inherited from Bitcoin) and yes, you can send without a fee but don’t be surprised if it takes many hours for it to confirm.

1 Like

How to pre-compute the right transaction fees? I mean, I’m developing a new GUI and I would like to show required fees before the user push on the “send button”.

Looking at bitcoin code I see they compute it on the byte of the input transactions. How to do the same on zcash? On what part of the source code can I take inspiration?


As I stated above, if you use z_sendmany the fee is always the same 0.0001 ZEC so there is no need to calculate a higher fee when the default one works fine.

I see, but in teory these fee are too hight and are they are not computed on the real transactions size like bitcoin does.

If you use the old RPC command sendmany it has the same fee calculation as Bitcoin because Zcash is based off of Bitcoin.

But most people don’t want to pay the higher fee for no reason. The z_sendmany will use the 0.0001 ZEC fee and the miners and nodes accept the fee.


I have a wallet with some t-address. I wanted to make a transaction to binance and used “zcash-cli z_sendmany”

Transaction did pass and have the output:

“id”: “opid-someidhere”,
“status”: “success”,
“creation_time”: 1526376514,
“result”: {
“txid”: “someIDhere”
“execution_secs”: 0.0479543,
“method”: “z_sendmany”,
“params”: {
“fromaddress”: “t1addrsender”,
“amounts”: [
“address”: “t1addrrecipient”,
“amount”: 2.4
“minconf”: 1,
“fee”: 0.0001

Before the transaction I had 2.47 in my wallet
After the transaction I have 0.00000000

Where did the 0.07 go? Can you help me identify the problem, please?


Look at your wallet for a newly generated t address. You will find the amount you are missing there.