(SOLVED) 2 identical CPUs i7 6700 gives different results

Hi, I've got 2 of i7 6700 CPU (Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz) machines and 1 is working just fine at ≈ 30 sol/s (which is normal for the CPU), while second one gives around 15 sol/s. Using nicehash/nheqminer. Configurations are 100% similar, both are bare metal with 32gb RAM, CPU usage is 800 %, RAM usage is 2GB on each of them. everything is the same, but speed is different. Any ideas on where to dig?

Are they using the same kind of memory? Are their memory channels configured the same way?

1 Like

Memory setup is slightly different. Here is "lshw -class memory" output for #1: https://gist.github.com/anonymous/1a0d725124abe7fca0739d7929bbbb4a and here is for #2: https://gist.github.com/anonymous/6e07f486434725f05b5fff101932d8dc

Could you please confirm if there's something that could affect the sol/s rate?

try using -t 6 (75% of threads)

1 Like

speed have increased to 17 sol/s, 6 threads are used (600% CPU, 1.2GB RAM). What can be meaning of this?
Also I've just tried -t 4 and it gives me 15 sol/s with 400% CPU usage. I'll now try to run 2 apps and set CPU cores to use for each of them manually

It looks like one of your systems can access its memory via two channels while the other is only using a single channel. Extra memory channels provide more bandwidth but, so far as I know, making the most efficient use of them at the OS and application level can be difficult to achieve.

With your 2x16GB system, try putting the 2nd memory stick in a different slot so that the slots are used something like this: occupied, empty, occupied, empty.

1 Like

@trolloniex unfortunately setting CPUs per miner instance didn't work - each miner's speed is 8-9 now which is almost the same as 1 miner with -t 6.
@Voluntary thanks for the suggestion - I will try to check it, but any other suggestions would be highly appreciated since it's dedicated server and provider is not too good in terms of support, average response time is 24h and I can't go with trial&error easily in this situation easily.

@Voluntary thank you, fortunately that did the trick - single RAM channel was the issue, after placing 2nd module to work on a separate channel I've got my 30 sol/s :slight_smile:

Thank you all, guys, for your suggestions and help!

@voluntary I'm really impressed you thought of that as the possible problem. I'm so dumbfounded that you thought of that as the possible problem, the only way it fits into my world view is that you also made the same (incredibly dumb) mistake....RECENTLY. LOL

If the i7-6700 is not efficient in getting ZEC. See if they have other cheaper older options like i7-2600 (21 S/s withDDR3 1333), or i7-3770 (23 S/s with DDR3-1600). Bascially any i7 or i5 that is not so new. 2x4 GB RAM is plenty.

Thanks, but I'm completely ok with 6700 for now since I know where to get it cheap :slight_smile:

It'll take some forum archaeology but if anyone goes back through my posts they'll see I've been banging on about memory channels and their potential to impact Zcash mining for quite a while.

Is that a 6700 or 6700k? Iv got a 6700 and get only 15 sol/s ... 28 h/s on suprnova pool... where am i going wrong?

it's 6700 (6700 = 3.4GHz, 6700k = 4.0GHz).
Since h/s == sol/s, it's not clear what you getting..

I get 15 sols/s when connecting to suprnova pool? Have you tried suprnova yet?

no, I'm fine with flypool. But probably you are either running into the same issue I did (single RAM channel instead of 2), or suprnova reduces hashrate on it's own. I guess first is more likely.

Actually its 28 sols i get my bad

yes, looks just fine