Stuck on blocks or Stopped on Activating Best Chain Solution

Dear All,
Glad to join the community! Hi to all of you!

Stuck or Stopped on Activating Best Chain?
Stuck on one block and not downloading any more?
I also tried re-index but this did not work for me.

I noticed that I couldn't find any real solution to this on the Support Forum.
I don't know if that's because it is seen as a simple fix to hardened miners or Ubuntu users?
I am neither of the above! I'm pretty new to it all!

Anyway, I managed to solve the problem.
I'm posting it here to help others.
BACK UP ENTIRE DIRECTORY JUST IN CASE :smiley: As with everything in life.
But I CAN CONFIRM I DID NOT LOSE MY 0.001 of a coin!

Firstly, Stop the Process if Zcash is already running.
I found you can do this by click the top icon on the left menu 'Search your computer'
Then search for system monitor.
Click System Monitor
Find zcashd and right click
Then Click Kill!

Next Go to the .Zcash folder
Find the Directory called Blocks
Rename this to Blocks.OLD (or whatever you want)
Then Start the process again with ./src/zcashd -daemon

This has worked for me. Im downloading blocks again.

I am currently mining at a very poor rate of 3Sols so donations are much appreciated!

zcTiQfYZpoRNTDHcEWJW7WE2PapPzQLx6HH53gW9nS3R4KQAf21EACqkSAi4ULZN3DL1j5qSNHrd3gH7Ja49so8Ab5ZVMp6

Happy Mining!

Doc