Update to zcashd 4.0.0 fails on CentOs

According to https://zcash.readthedocs.io/en/latest/rtd_pages/zcashd.html, I tried to update zcashd to the v4.0.0 on two servers running with CentOS Linux 7.6.XXXX.

For both I got something like the following:

At global scope:
cc1plus: warning: unrecognized command line option “-Wno-builtin-declaration-mismatch” [enabled by default]
make[2]: *** [libbitcoin_server_a-sendalert.o] Error 1
make[2]: Leaving directory /home/zcash/src' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory /home/zcash/src’
make: *** [all-recursive] Error 1

Tried a “make clean” before building the update, with no success.

Any idea ?
thx

Autotools commands do not behave as expected in Zcash due to the way the depends system is set up.

Try the following:

$ ./zcutil/distclean.sh
$ ./zcutil/build.sh

Unfortunately, it didn’t work.
Then, I removed the zcash folder and performed a git clone, but still the same behaviour… impossible to compile the version 4.0.0

Are you using a 32-bit environment by any chance? Zcash requires 64-bit.

Also make sure the server has enough RAM.

Hello,

Thanks for replying.
Yes, 64bit OS and 8GB of RAM.

Actually, I’ve been running 2* Zcash full nodes for about 3 years. This is the very first time the update (or install) doesn’t proceed properly. Maybe an issue with the dependencies, I am going to look into it…

@Shawn is it possible to forward this issue to the tech team ?

Could you please try building latest master of https://github.com/zcash/zcash ? It’s building fine on (what I believe is) CentOs 8: https://ci.z.cash/#/builders/17/builds/402