Windows Zcash v2.0.1 command-line release


#1

I’ve just uploaded my binary build of command-line Zcash v2.0.1 for Windows to:

https://zcash.dl.mercerweiss.com/zcash-win-v2.0.1.zip

The sha256 hash of the zipfile is:
3f229e7470ee1f3c46b7c0de4ef79edc5a4779f51c70d4b5ef75bbd70df7140a

You MUST also download the following 3 new parameter files into the directory %AppData%\ZcashParams\ (which is a hidden folder but you can cut and paste that path into Windows Explorer to move them there after download):

https://z.cash/downloads/sapling-spend.params
https://z.cash/downloads/sapling-output.params
https://z.cash/downloads/sprout-groth16.params

The last one is the big one at just under 700 MB.

Note that this release has only been tested on Windows 10 and Server 2k16, and that some users have had issues with past releases on older versions of Windows.

If you want the nice ASCII/ANSI art, you must launch zcashd.exe in PowerShell with the following command from wherever you unzipped it:

.\zcashd.exe -daemon=0 -showmetrics=1

and as always, backup your wallet.dat file before running a new release! its in %AppData%\Zcash\ as is the debug.log file, which I’ll need the last 20 or so lines of if you have any issues! :slight_smile:

I can’t wait for Sapling activation, it is so fast, single digit seconds to do a Sapling send on testnet!

Cheers,

D. Jane MercerWeiss
Denver, CO

PS: We’re scrambling to get Sapling support done for WinZEC now that Sapling-ready zcashd.exe is out, but its been a rough month: my car is not working, I’m drowning in medical bills, and of course this is the month my son breaks his eye glasses and needs new ones. While we do have some regular ongoing funding now, on top of the above we’re still paying move in costs for our apartment here in Denver, so anything you can spare in $crypto is very much appreciated! Donation addresses at:

https://zcash.mercerweiss.com/index.html#Donations

PPS: for the lazy you can drop some of that filthy fiat at https://PayPal.me/MercerWeiss
Thanks again everyone for the community’s ongoing support!


Zcash-qt-wallet now supports Windows!
#2

DISCLAIMER: as always I’m not an employee of ZcashCo or the Zcash Foundation


#3

I mean at this point I’m down to $40 for the next 10 days while working on Sapling compatible WinZEC so every penny/zatoshi helps


#4

Thank you for all the work @radix42 on this! I’ve been doing a lot of transfers the past months so I hope it helps… at least a bit :slight_smile:

Will be patiently waiting for the WinZEC.

Take care!


#5

yeah Sapling WinZEC is going slowly, rpc changes have made it very unhappy


#6

What are the outstanding issues, as it works nicely for me swapping in the updated binaries? I just had to create the Sapling address via the command line but once I did I tried all the functionality on WinZEC and it seemed to work just fine (I didn’t try importing a key but I would imagine this works).

Could you just change the “New Z (Private) address” to just call z_getnewaddress sapling. Would there be a reason to support generating Sprout addresses once Sapling launches?


#7

I get stuff like this, even when I do the hackish thing you just described of dropping in zcash 2.0.1 binaries into c:\Program Files\winzec\app\


#8

it get’s through “Loading wallet…” on the splash screen status, and then this :frowning:


#9

Hi @radix42, what’s in debug.log after init message: Loading wallet...? Any error messages or anything unsual?


#10

Nothing weird in it at all, normal functioning until the WinZEC GUI essentially says “nope, I"m out” and does a clean shutdown


#11

what version of Windows are you running on?? and anything fancy in your zcash.conf


#12

grasping at straws here rn


#13

Windows 10 home and nope nothing special in zcash.conf. I did start with a fresh wallet before importing keys and performed a reindex (the latter as I accidentally after testing the 2.0.1 version on testnet started up the old version). That’s always worth a try?


#14

yeah I’m gonna try on a clean machine tomorrow


#15

omg I should have paid more attention to the “socket already in use” message(s) and tried The Windows Solution™: “have you tried rebooting?”

That’s all it took, all is well, back to actually being able to write more code

cc: @bitcartel


#16

Sapling-ready WinZEC 2.0.1 is up now at WinZEC.com :slight_smile: