ZEC stuck in zcash4mac wallet! (Error 18 when sending)

Hi everybody,

to sum it up: I am fucked up! I have my ZEC in my wallet zcash4mac in a z address. Now I wanted to move them to my ledger and first step was to send my funds from the z address to my t address in my zcash4mac wallet.

The problem is, sending is not at all possible! I always get this error message: “An error occured when sending cash. Error message is: 18: bad-txns-joinsplit-requirements-not-met Please ensure that sending parameters are correct. You may try again later”

I tried it multiple times. Varied the sum that I was trying to send. I did a -rescan and -reindex command in the terminal. After synchronizing the whole blockchain (like 2 days) I get the same error message.

Can anyone give me a hint what else I could try? I am really desperate and afraid that the whole ZECs are lost…

Does anybody habe similar issues with the mac application? I am not aware how to vary the parameters since I am using the GUI.

Thanks for any hints!!!

I don’t recall the exact error I was shown but I’ve had something like that happen with the Swing wallet a few weeks ago. Somehow I was able to send transactions until a minimal amount of unspendable Zcash was left in my z_address. I’ve since done a fresh OS reinstall and haven’t gotten around to installing Java again to reproduce the error and report it properly…

Hi, maybe the guy who is programming zcash4mac can help you?

the gui is deprecated, one should use the command line version according to zcash4mac.com

Yes, I think the update is the problem that zcash4mac is not running anymore.
Downloaded the 1.0.15a release and synced the blockchain.
ZEC transfer with the GUI still not working (another error code)
trying to do it with the command line tool, but before it has to sync the blockchain again…

Is there a way to see the syncing progress with the command line??

So I tried to do the transfer from my z address to my t address with the command line tool but unfortunately it failed… error: “Could not find previous JoinSplit anchor”

Any ideas what could help solve the problem? Thanks!!!

This is the github issue I created for what sounds like the same problem. Perhaps you will be able to provide more specific error details than I’ve been able to… https://github.com/zcash/zcash/issues/2938

Well, I am not that much a techie…
I tried it now multiple times. And after doing a -rescan and then doing the transfer manually it finally went through!!

So thanks for all the support here! I hope I can now transfer the ZEC smoothly to my ledger wallet…
:slight_smile:

I’m glad you managed to send your ZEC. I suspect this problem is due to a build up of change transactions coming back to the same z_address…

i have enother error, may be this script can solves your problem too

1 Like