ZEC.suprnova.cc is not working

I tried to log in, and it kept giving me log in failures.

I sent them a support email a week ago. No response.

Suprnova in general is a bad site.

I can’t link my zec address to my registered account. It claims that my address is not my address.

It seems they are just thieves. I have some coin i want to get out of there, and they keep blocking my account.

I used the correct log in, and it keeps telling me it’s not.

I reset the password, and use it and it still won’t let me log in.

Anyone else found that they are dishonest? I just want to get my money and leave them forever, but they don’t even respond.

It tells me my account is locked, and to check my email for instructions on unlocking it, then it doesn’t send me any email. This is the same email I JUST used to reset password (back to the exact same password.)

Also, I was mining signatum on suprnova, and they just stole 9 signatum from me then locked my account and disappeared.

Then I tried to mine with slushpool, and they keep telling me “please enter valid username and password.” But I am using a valid username and password!!! The recaptcha worked just fine, and I have sent a support request. What is wrong with these people?

Oh, wait different pool. Signatum pool okay now.