ZECWalet-Lite: Lost funds while shielding t to z. Please help!

Describe the bug
Sent ~3ZEC from t-address (zecwallet lite on android) to z-address (zevwallet lite on Linux). TXID exists, 100+ confirmations, funds never arrived on z-address.

To Reproduce
Send funds from t-address to z-address.

Expected behavior
Funds should have been received on z-address.

Desktop (please complete the following information):
Android OS zecwallet-lite (1.1.2 - latest)
Linux OS zecwallet-lite (1.2.2 - latest)

Additional context
Tried the following:
Rescan on both.
Restored Android device’s wallet on Linux. It shows incoming tx, but not the outgoing tx, which this problem relates to, yet balance=0.
Restored Linux device’s wallet on 3rd device (Android tablet). Also shows balance=0, no incoming.

CC @adityapk00

Realized zecwallet on Linux not latest, updated to 1.3.3. Issue remains.
Also tried on Linux removing (renaming) .zcash and .zcash-params, started with new, recovered from mnemonic and block 0. Issue remains.

Reminder, here the restored wallet is the sender wallet and this behavior is probably normal, as the outgoing tx is the shielding one. This probably would not show up anywhere except the android device. By incoming, I mean the original receipt of the ~3ZEC (t-addr to t-addr), which went missing during subsequent tx. However, the balance=0 is essentially correct, since txid generated during shielding tx is confirmed.

Are they fully synced?

Yes, it just appeared. I think I didn’t restart my wallet after update to 1.3.3 or maybe it really took 4-5h for some reason, the wallet on android tablet didn’t show it either, now it does.


However, they were all at the same block as far as sync… Mystery and relief

1 Like