Why can't ZecWallet. Lite convert my t-address to a z-address?

I have been unsuccessful with converting my ZEC balance from a transparent t-address to a shielded z-address using ZecWallet Lite.

On the “Send” tab I pasted my wallet’s z-address (where it says “z-address or t-address”) and then selected “Send All”.

It appears to work initially, and a I see a message “Computing Transaction. Please Wait” after which I see the message “Successfully Broadcast Tx: xxx”.

However, my balance stays as a t-address.

I have tried this three times over the past 24 hours without success.

I am new to zcash and ZecWallett Lite. Can someone help me understand how to convert my ZEC holdings from a transparent t-address to a shielded z-address?

Thank you.

1 Like

The successful broadcast msg would indicate that the tx worked, you can check past txs and confirm that. If the wallet balance appears incorrect then you can resync the wallet from the option tab up there on the top. Also be sure your using the most recent release, using old versions can produce errors that might affect the balance that you see.

I just tried to send from z to t and then from t to z and it works just fine. Maybe make sure you’re pasting your z-address in the send tab, and not your t.

How are you confirming you balance is staying as a t addr?

Yes I conformed that I am sending to my z-address. Maybe “Send All” isn’t leaving enough for the transaction fee (see attached screenshot)?

Confirming that my balance begins with a “t”.

That amount being only equivalent to a tx fee could be actionable. Typically Zecwallet enforces the minimum network tx fee of 0.00001 so if thats the total balance then sending any amount would exceed it. I’ve never done a dust tx on zecwallet, might have to look into that.

There is several hundred dollars in my ZeWallet t-address, and I just assumed that “Send All” would do as you describe and calculate/deduct the transaction fee so that the transaction would go though.

I have confirmed that I am unable to send my t-address balance to my z-address using both the macOS client “Version 1.7.8 (48)” and the iOS client “Version 1.7.8” of ZecWallet Lite.

Maybe I should try another client other than ZecWallet Lite to transfer my zcash balance from my t-address to my z-address?

Can you confirm you taddy balance with a block explorer? Such as https://explorer.zcha.in

This is what the block explorer shows. What does “Transparent Balance 0 ZEC” mean?

It means that the initial T → Z send all tx was, in all likelihood, successful and that it seems to be some issue with the wallet ledger not updating the correct balances. Perhaps @adityapk00 might have some insight here.
If you have another device you could try restoring the wallet with the seed on it and if that works (it should) then that could at least help narrow down what the problems could be.

According to that screenshot, you sent all of the Zcash from one “t” address to a different “t” address. So the balance left in the original address is zero, all the funds are in the new “t” address.

There may be some confusion here.

Be sure when you send to a private address it starts with “zs” and not a “t” otherwise you are just moving funds between transparent addresses.

1 Like

This is what I thought from his initial description, that he sent to a t address, instead of the z

Yes, your txn seems successful. It just doesn’t show up as an independent transfer when you shield within the wallet (your own t addr to your own z addr). That is why block explorer shows t-addr is empty - your funds are now in shielded address I bet.

I am not sure where you might be seeing that your balance has an address that starts with a t? Is it in the wallet tab? If so, that is likely the outgoing transaction for shielding - not your “account” balance.

Lol ok maybe not given the screen shot. But my point above stands for auto shielding txns.

I’m not sure what happened if you sent it from t to t. Good thing unified addresses should get rid of all this confusion!


Oops I didn’t see that it was t2t, Ive just never seen the successfully broadcast tx msg as an error
Assuming the taddy is owned by the sender (which they claim) then it should just be there and spendable. I don’t know about yall but I’m pretty compulsive about thoroughly checking the addresses before sending.


I never did t2t. I always transferred t2z, i.e. I did “Send All” to my ZecWallet Lite z-address three times. It seems like ZecWallet Lite has a bug that doesn’t show that my balance is held in a z-address instead of the t-address.

I changed to Nighthawk Wallet and sent my funds to Nighthawk from ZecWallet Lite, and now my balance is as I expect - all of my ZEC holding are in a shielded z-address.

I like that Nighthawk Wallet shields by default.

So, I was able to solve my own problem by changing to Nighthawk Wallet. Thank you for your help everyone.