Anyone still having only 4~5 GPU detected in Windows 10?

Hello Guys,
I having some problem here, my mining rig only able to run in max 5 gpus, no matter how i swap between pcie slots, still only 5 detected. I know this is a common issue, there is alots of people facing this & might found their solutions, but i tried most of them... non of it works for me.... Below is the specs & stuff i did

OS: Windows 10
CPU: Pentium G4560 (Was G4400, saw a post about skylake & kabylake limitation so i tried both)
RAM: Apacer 8GB 2133mhz Ram
SSD: Apacer Panther AS340 120GB
PSU: Segotep GP1350 1250Watts 80+ Gold
MOBO: Gigabyte GA-H110-D3A Mining board (Flashed Latest Bios, Mining Mode on)
GPU: 6x Gigabyte GTX1070 (Mix with Auros, G1 Gaming & Winforce edition)
Raiser: PCIe PCI-E x1 to x16 Riser Card USB3.0 Sata Power Connector

Stuff I did
- Flash Latest Bios Version F23a, Mining Mode on, GEN 2(was set automatically by bios once mining mode on but tried GEN 1 too)
- Onboard Graphic On (Bcoz i not sure if able to connect my screen to one of the 1070 with raiser connected)
- Tried to turn off Onboard graphic too, same thing happen, only 5 gpu shows
- Enabled 4G Decoding
- Nvidia Latest Driver Installed ver 384.76
- Changed virtual memory paging file size to 20000mb
- Installed MSI Afterburner (Using it to detect GPU always shows 5xGPU+HD610 onboard GPU)
- Tested every single raiser to make sure it's working fine (basically test every of them by plug in any of the PCIE slots with single GPU)
- Tested every single PCIE x1 slots (basically test every of them by plug in single GPU with raiser one by one, restart pc and run afterburner to check)
- Updated drivers via device manager > update drivers (Did this due to previously was only 4 GPU detected, tried everything except this helps to get the 5th gpu works)
- Tried with Latest Ubuntu, still same only 5 gpu shows

Please any advise or guidance is deeply appreciated, been struggled for days on this problem. TQVM

I hate throwing out this suggestion, but you mentioned you’ve been struggling for days…: Have you tried wiping the hard drive and starting over from square one? I only suggest this because I was in the same boat a while back and when I started over, everything worked just fine; apparently had something tweeked somewhere.

Also, have you tried each GPU solo to make sure one isn’t faulty?

Yup, i’ve actually tried Ubuntu, at first i thought was Windows limitation, but turns out same problem with Ubuntu. I tried each raiser + each single GPU to test hardware condition, all works fine, thats what i did for days… i suspect it might be something missing with bios settings

u should use asus z270 a or p , i see people running 8gpu,s on it

Usualy, it is a Win 10 problem. Is your win 10 32 or 64 bit? Anyway, you must update win 10 to last 1703 version. Download and use windows update assistant. It is fastest way. Also, did you gave your win 10 extra 16gb shared memory?

Have you solved this issue? Having the same issues with very similar hardware.

To be clear, did you try a Windows reinstall, or you only tested on a single Windows installation?

I was having issues with my z270a and 8 gpus (2 weren’t showing). Wiping windows 10 and doing a clean install fixed the problem. I have no idea why - just a windows ‘feature’ I guess. :wink: