Cant get windows to locate GPU

So i cannot get windows to show my 4th gpu.I have made sure my virtual memory is at 16000, reinstalled windows, reinstalled drivers.

its 100% not a hardware issue. I swapped out pci, usb, power supply cables with working ones to verify not hardware. also tried a different pcie slot. if i move the 4th gpu in place of #3 gpu the pc sees it still but not the 4th. therefore i know its not hardware related.

im running a msi 270a pro board, celeron processor, 4gb ballistix ram, 120gb solid state, 4 msi 1070 gpu on riser with corsaire platinum psu, running windows 10 pro

i have reinstalled nvidia drivers and checked for update. double checked virtual memory and bios settings. gen 2 and mining mode is on

i dont see any onboard graphics to turn off in settings.

msi afterburner only shows 3 out 4 gpu

Agree that nothing in your hardware selection looks problematic. As long as your risers aren’t acting up, you should be good to go.

The most suspect BIOS settings that could cause the issue from your description:

  • Enable 4G Decoding (ON)
  • PCI-e (GEN-1 or GEN-2)
  • All SATA ports not in use (DISABLED)

I think the MSI BIOS should automatically disable all the SATA ports that are not in use, but I’m not 100%.

The MSI motherboard won’t have it’s settings in the same place as the 270 in our mining rig build, but look for the settings by clicking through your BIOS and find the ones that you can. Settings are in part 3.

Hope it helps!