Asrock BTC PRO R 2.0

Looking for help with running 6 GPU on this board with windows 7
No matter what I do one GPU is showing code 43 it does not apply to any pacific GPU as if I install driver manually for this GPU it fixes problem but another GPU will report same error, board is setup correctly and running xfx pro 1250 W power supply with USB powered risers using 6 GPU mod, I can run 5 GPU with no problems and using all RX 480 hope someone found a fix for this and can help

1 Like

I think the problem is in drivers. Your cards bios are flashed and you using latest driver? If yes you should go with driver 16.9 or 16.10

@kapsi thanks for your help,I tried everything I could think of and I am experience user,I tried drivers but only latest before the revive drivers couple of different ones, you are correct this is a driver issue but I took the free upgrade to win 10 last night which can take some time with these low power intel cpu left mining and got up this morning to fresh install of win 10, will go setup now and don't expect any issues

i tried to use a hacked driver but only got 5 GPU on, another extra is nada.

Hi @privatenode yes it's a nightmare I changed to windows 10 and still only 5 working but changing GPU number 6 to the display GPU plugging in HDMI cable and was detected and problem solved,win 10 would boot but to black screen with 6 GPU's until changing last GPU for display I don't know if win 7 would have worked doing this as never tried but good chance it would have, I am using a mix of xfx 480 xxx black edition and Gigabyte G1 gaming 480 maybe this can help others

I am having the same problem in Ubuntu. I can get 5 rx 480 to run fine but that 6th card causes problems. I did switch it to the 6th slow but now it gets past boot but HDMI source is showing nothing. Any tips?

For me my settings are bios change from auto to gen 1
Pci-e slots are numbered 1 to 6 with first x1 slot number 1 full length x16 slot is 2 and I had to use first x1 slot for my display so plug HDMI cable or whatever method u use in to GPU here first x1 slot
For this to work I had to start with 5 cards just unplug pci-e power cable from 6 card and install drivers then power 6 card which will be in pci-e X16 slot with your x1 riser and change HDMI cable to 6 card (otherwise my PC would boot to black screen) when you now turn PC on your card 6 will be detected and driver will instal but since ur not using windows might have to instal manual
Before turning PC on you must switch of power supply and unplug for couple of minutes to allow discharge then power up so changes can be detected
Hope this works for you @Eon

Without changing any hardware setup I changed from AUTO to GEN1 in the bios and now two of my 5 boards are only mining at ~50% speed, while the other 3 are working fine. Did you notice a sol rate drop after changing to gen 1?

No all 6 are mining full speed
There is reports of rx series cards running at half speed if running headless
Rx series need to be contacted to a monitor to work properly or you can trick them into thinking they are connected to monitor buy using a dummy HDMI plug,you can also use a HDMI switch
Also try stopping mining software and start again
Uninstalled drivers in device manager of effected cards and scan for hardware changes to install drivers again
Change from gen 1 to gen 2 in bios to see if makes a difference

I'm running Ubuntu 16.04 server with this board, and I have some odd issues as well.

I've set the BIOS for integrated graphics (may be the issue), and Gen1.

The first oddity is that the fifth x1 PCI connection never detects a card. I've switched cards, and I've switched my USB powered riser. Nothing ever gets detected there. I suspect a bad board?

The second oddity is the card in the x16 slot runs at 50 S/s while the other four identical RX480 cards run at 200 S/s. This may be the monitor issue, and I'll try that.

Other hints/advice appreciated.

Yes do not set for integrated graphics you must set for pci-e graphics and these rx series must be tricked into thinking they are connected to a monitor
I suspect as you have set for integrated graphics this is causing problems as u suspected and if running headless this will cause card to run half speed that's a known issue

Having the integrated graphics on was the issue.

I plugged into the HDMI on the x16 card and it now runs at 1/2 rather than 1/4 speed. But, I would think it would be full speed now that I have a monitor plugged into it. Or, do I need to set-up a dummy X11 setup also?

No should be all good now try going to watman and reset all cards to defaults and use DDU or AMD driver uninstaller then reboot install drivers again, this seems to be a corrupt driver issue as far as I can see if you have not tried this yet, you only need one HDMI cable plugged into your rig to overcome the problem with rx400 series cards
Have you tried to restart miner a couple of times to see if that fixes issues? If u have move to driver uninstall as this will be your issue, u are nearly there hang in there