Mining with more than 1 video card problem

Rig
ASRock H81 Pro BTC
4 gig ram
Intel Celeron G1840 Duel 2.8
60 GB SSD
5 x PowerColor RX480 8 Gb
5 x USB 1x to 16x riser cards
1200 W power supply
Windows 10
Nmeqminer

I am able to get the system to recognize all the cards but when I mine with 2 or more cards it crashes. I'm thinking the video drivers are no working. I read about custom Roms but not using them. Help!

Thanks in advance,

Roger

Try changing the slot cards: What drivers you use?

The standard windows default driver for the card. It works for everything except mining. I have tried rotating risers to different slot. Still the same problem.

Hey guys , I'd be happy if you could help me.
I'm having problems setting up my 6th card on msi z97 gaming 5 mobo.

I have 6 rx 480 8gb cards and I'm using a 1600 watt psu on windows 8.1.
I tried the same setup with windows 10 but it still doesn't work.
I have even changed the pcie speed to gen 1 .

Please help.

You got 5x cards to work with no problem? Lol I can't get past 1. Is it a 16x slot? I've heard/read you need a 16x riser to make them work.

YyZ

  1. check in the bios if the slot shows used
  2. change pci to gen 1 or gen 2
    3 change to 8x4x4x
    4 change latency to 64 or 96

if that doesn't work then you got a hardware problem

1 Like

I have the same motherboard and the same problem trying to run more than 5 RX 470s on windows 10 I'm beginning to think its a problem with this motherboard

Seems to be driver issue to me.. I had EXACT problem. I would try fresh install of windowns 10, don't plug internet in and install driver with ALL cards plugged in at first, ( takes longer but worked for me )

It will always crash during driver installation when I have more than 4 cards plugged in

Update BIOS and make sure it is set to gen1

In bios I have the option to set PEG0 PEG1 and PEG2 to gen 1/2/3 I've tried switching all of them to gen1 and even tried gen2 didn't work. its on 8x4x4 configuration

@minerman

Hey I managed to fix the issues. Please follow @cryptomined posts. He has some tweaks for the mobo.
Also, check your riser. One of my riser was faulty. The moment I changed the riser, it detected the 6th card automatically.

1 Like

Try fresh windows install then... Like I said I did that and installed driver and worked for me
.. Also check molex or sata connections to PSU from risers

@amintarang What did you do besides that? cryptomined has been helping me but which tweaks are talking about in particular? I'm able to get the cards detected in windows but when I start mining one card will do 0 hashes and will eventually crash

I'll give you the settings.. as suggested by cryptomined.

Pcie speed - gen 1
Pcie lane 8x4x4x
And latency to 96 units

just tried those settings and they aren't working either

Try changing your risers. Maybe they are faulty. I was in the same position as you till an hour back, the moment I changed the riser on the card that wasn't getting detected, voila.

awesome glad it worked for you :slight_smile:
if your using gen1, try gen2, sometimes gen1 gives less hashrate than gen2, and gen2 should work fine.
if its working now with gen1, see if it will work with gen2

id try other risers if you just cant get it to work
you have your primary display adapter set to PEG (video card) and not onboard /intel right?

I tried ctyptomined possible solutions/tweeks and not working. So it must be hardware. Because of this I've ordered new riser cards, ver 6, and we will see. I'm finally, starting to see a bigger picture on how this works (I think). I will let you know if it works out.

Fingers Crossed,