ASRock H81 problems

I have read many threads with similar issues and at this point I feel like I’ve almost tried everything to get this motherboard to mine with 6 GPUs. It will detect all 6 cards but when I mine with it a random card will have 0 hash. Mining with 5 card there are no issues and at least I get to choose what card isn’t mining this way haha. Here are some things I have tried to help fix the issue:
Set pcie to gen 1 in bios
Setting 16 Gigs of Virtual Memory
Updated drivers (didn’t work so I reverted to blockchain drivers)
Switching risers
Trying completely different cards
Trying all PCIe slots with 5 cards (this worked)
Updating the Mobos BIOS to Version 1.30B
Updating Windows (I’m using Win10 home)

It was around this point where I started running out of ideas… so I tried:

Clearing CMOS
Dusting cards?
Switching RAM

Any thoughts? I’m sure there is something I probably missed. I read similar issues where people couldn’t get a 6th card working but they just couldn’t get the 6th card to be detected. My card is detected just fine and shows up as what ever card I slot in the 6th slot in both MSI Afterburner and in the mining software. For my mining software I’m using Claymore. My config file is pretty standard, just intensity of 9 (that reminds me, I tried setting different intensities but I’m pretty sure this isn’t the issue anyway) and everything else on defaults. I was thinking about getting an ASRock h110 pro BTC for another rig. Anyone have any good experiences building with this?

Edit: I may have fixed it??? not really sure what I did but oh well