Issues with H81 pro BTC 2.0 + 6x rx470

Hello, I am stuggling since 2 weeks to make my 6th card work.
They are MSI 470 gaming X 4GB Samsung memory card, all of them same batch.
Im on Windows 10 64bit pro.
USB powered risers straight from PSU
I swapped cards and risers and they work and mine correctly independently.
When I book the detection of my 6th card is random, sometimes its detected sometimes not, and when It is I get BSOD or only 5 card are mining and 6th one is idling at 0MH/S...
Here is what I tired :smile: :smile:
- Clear CMOS
- Set PCIE to gen 1 (in GPU Z one GPU displays PCIE x16 3.0 @ x1 1.0 and all other 2.0 when I have 5 card detected on 6... and when I have 6 cards detected all slots are at 1.1 and only one at 2.0, can this be the issue ?
- My power supply is 1200W gold rated zalman 1200 EBT
- My ram is random 8gb stick
- 6 GPU PATCH
- Should I try pixel clock patch ? I didnt try
- Reinstall Windows
- Tried mining with simplemining.net linux software : only picks up 5 cards too
- Claymore miner different versions
- Drivers 16.9.2 (currently mining with 5 card on that with success) / 16.11.5 / 17.4.3
- Plugging MOLEX to the motherboard 4pin slots
- Drinking a lot of cofee
- Watching eth pump

Im quite desperate about that last card, and I guess it will end up in my gaming PC and mining from it if I dont find a solution :frowning:
Here's a pic of my rig. https://s3.postimg.org/ra9yra0fn/20170504_200752.jpg
Im kinda sad it doesn't work as intended, I even painted the frame black myself :open_mouth:

I have managed to make it mine with 6 GPU full speed on claymore but only for 2 minute, after that it crashes, video driver seems to hang, and I must reboot, and next boot it will only detect like 5 card... and I must reinstall all drivers...
Is there a particular driver that I can use that is safer and more stable ?
I have tried with and without molex extra pins plugged to motherboard, no success.

My card setup is like this :
A PSU molex cable 1
B PSU molex cable 1
C PSU molex cable 2
D PSU molex cable 2
E PSU SATA to molex 1
F PSU SATA to molex 2 + hard drive sata

Its been two weeks I am trying different things with no success for stable 6 card mining...