Associate T-address to Z-address


#1

Hello

I begin with ZEC mining. My zcachd is running, with a Z-adress and I create a T-address to mine on Pools
But after some hours (and some tests on zcashd to solo mine), I loose my T-address in my list
Z-address is still here, but no more T ...

Is it a way to re-associate my t-address in my wallet ?


#2

You're not losing any addresses, you just need to exec

$ zcash-cli listreceivedbyaddress 0 true

#3

Thank you, but my first T-address is not the same as this listed by this command ....
First was t1WAoinB9ChsS8APMdpF5TTFvp2K2ibKjG4
Current is t1Zs2DWXLRmMB7wDvKX9S438nnFctwKEvXx


#4

I have news : if I try to use my original ~/.zcash directory (fortunately backuped), I have an error
Verifying wallet... and stop
In db.log ;
wallet.dat: BDB0090 DB_VERIFY_BAD: Database verification failed
BDB1009 /home/seb/.zcash/wallet.dat: unsupported btree version: 10


#5

Shouldn't be losing your t-addr unless another party is unknowingly exporting your wallet, making a cp for themselves remotely, purging the t-addr from said local backup, re-importing local backup and getting the zec's destined for your wallet; highly unlikely but plausible.
Can only suggest to back up your wallet, hash it or better, sign with your pgp key so you can verify their unique signatures and replace the payout t-addr in the pools with one of your current or a newly generated t-addr:

$ zcash-cli z_exportwallet wallet.bak
$ sha256sum wallet.bak wallet.dat > wallet.bak.sha256

#6

Run db_dump ~/.zcash/wallet.dat to second check validity of the db.


#7

issue identified - https://github.com/zcash/zcash/issues/1694#issuecomment-257039402


#8

It's much better, this issue solved my wallet problem ... but it seem's my block .dat file are corrupted too and the db_dump solution doesn't work this time

Zcashd stay's on "Init message: Activating best chain..."


#9

delete ./zcash block folder content (index..) it happen to me and even reindex didnt fix


#10

did @5thdimension's suggestion resolve the Init while of hell?


#11

Hi
Deleting the blocks dir unlock the startup, but I have the same result as begin
T-adresse is t1Zs2DWXLRmMB7wDvKX9S438nnFctwKEvXx ....

I think I made the .zcash backup too late, and my first t-adress t1WAoinB9ChsS8APMdpF5TTFvp2K2ibKjG4 is lost ....