Biostar TB250-BTC Pro (12 PCIE) event viewer flooded with PCI errors

Hey guys, did any one came across this:

Connecting any of the cards to ANY of the PCIE X1 slots generate TONS of these event IDs, and the rig freezes and reboot after random time (minutes).

if the same card is connected to the yellow PCIE x16 - then no errors occurred and everything runs fine.

what i tried:

  1. update BIOS to the latest
  2. Change all to GEN2
  3. Change all to GEN1
  4. install Chipset drivers
  5. Test different risers
  6. Test different cards

nothing helped. each time a card is connected to PCIE X1 - i`m flooded with these events:

A corrected hardware error has occurred.

Component: PCI Express Root Port
Error Source: Advanced Error Reporting (PCI Express)

Bus:Device:Function: 0x0:0x1B:0x0
Vendor ID:Device ID: 0x8086:0xA2EE
Class Code: 0x30400

The details view of this entry contains further information.

anyone ran into this issue ? @cryptomined ?

2 Likes

i’ve seen this in various models, not just Biostar’s, and in all case we had it was 1 or 2 dodgy PCI-e risers. The problem is a dodgy one is hard to locate, exspecially with 12 GPU’s. We useally replace them all and retest on a 4GPU rig to see which are broken … or just throw them away of their the pre V6 models as their dodgy anyways.

Also try diff PSU’s and make sure you have enough power. You can also set the TDW to 55% and use all cards. If its a high-end PSU usage issue in most cases this would just ‘work’ without problems.

Also are you using a CPU that supports enough PCI addresses? Not all do (!)

Finally:
Bus:Device:Function: 0x0:0x1B:0x0

Is this the same for all? This is a fixed slot which might be dodgy.

And try linux, my exp. is that it has more detailed error logging, but again … for us its 99,9% sure its a riser issue.

3 Likes

i tried with only 1 card, that works perfectly on the x16 slot (same card and riser) - it was on all night and 0 events.

once i moved it to an x1 slot - events starts piling up and the rig crash after about 10 minutes.

i also tried brand new 6pin raisers, so its not the raisers.

sorry, never seen this issue, i hope you get it fixed though

@godanubis Have you been able to make any improvements on this error? I am getting flooded with these errors also on the same board, I’ve been disconnecting cards all night to narrow it down.

first answer helped me:
https://answers.microsoft.com/de-de/windows/forum/windows_10-hardware/windows-10-whea-logger-id17-behobener/ce3c60b9-d416-4f25-b9f5-061d135e1062

long story short:

Start (cmd) as Administrator.
bcdedit /set pciexpress forcedisable
enter
restart pc

I just got done fixing my setup on Biostar-BTC-Pro and it was a bitch.

Did you ever fix this? If not message me https://www.facebook.com/robert.solomon.50115