Hi, I’m afraid I have blundered significantly in trying to learn about the new unified addresses. I sent a small transaction first, and I thought it worked and that I had an understanding.

Anyway, my transaction IDs are



and when I look at the transaction fee, I see an absolutely horrifying amount that I did NOT intend.

Unfortunately, my node has gone to “rescanning” for the past day and appears to have several more days (weeks) to complete before I can check my unified addresses.

Is my ZEC gone to miners?

1 Like

Where are you viewing the transactions? Some block explorers don’t compute the fee correctly.

I had been hoping it was something like that. So, I tried two explorers, blockchair and zcashblockexplorer. BOTH show the exorbitant fee, however one of the two transactions appears stuck in the mempool most likely for lack of fee!

I guess it’s possible my mind is running wild, since my node is stuck rescanning and I can’t verify the funds (they’re sourced from the sapling shielded pool).

Do you know of an explorer that displays fees correctly?

I see a 70+ fee… it might be correct…

This shows the raw transaction and amount transferred across the pools. It is included in block 2294559 which has a fee of about 0.00250206 (if my math is right). Other txid does not appear to be valid and so may have expired.

1 Like

thanks for that Auto…I appreciate your going to a deeper level. Your post is reassuring, which at this point is all I have until my rescan is done.


The fee you paid can be seen in the difference between the spends and inputs, 1000 zat

The reason that you see this total amount is because it transferred from orchard to sapling or the other way around and the block Explorer does not parse that from being different from the fee. It’s a known issue


I didn’t read the raw transaction. Well spotted


Thanks again, this post has been worth whatever doxxing I’m now vulnerable to.

BTW, in the transaction that has expired, what happens? Return to sender?


Pretty much. Since the transaction was not mined, the notes committed to it were never spent so it’s as though it never really happened.

If the balance is still incorrect after certain amount of time has passed like a few hours then you can perform a rescan or checkpoint rewind to fix that. It’s not common but I have heard of it occurring.


This post was flagged by the community and is temporarily hidden.


No block explorers are maintained by ECC or ZF, nor wallets (not considering Zashi which isn’t officially out yet). So… how are they related to this?


True, this negativity is exhausting.

Not just that, Zooko can Tweet whatever he wants just like Dodger can do whatever he wants.

Guess what else is complex: AI. Do people still use it by millions? Yes.

Improvements have been made in many areas of Zcash, including UX, in the recent past.

1 Like

The nighthawk apps team is maintaining the zcashblockexplorer. They have a grant of more than 300k (which covers the wallet and lwd too).

This bug has been reported several times and it should be a trivial fix.
Yet, it is still there.

Fee = tin - tout + znet + onet

It is all there in the json response from zcashd.


following up…Autotunafish nailed it…funds are SAFU. :pray:

I normally research unexpected results prior to posting, including in this case. I’m not sure what I would have turned up had I continued on my own. It was nice to have the ZEC community’s direct response in this matter.


@Autotunafish is an indispensable human in Zcash. Many of us would be lost without him.