Can’t get 3rd gpu recognised on FM2A88M Extreme4+

I litteraly tried connecting the cards every diffrent way I could think off, but it still only recognizes 2 cards it doesn’t even show the 3rd one in the Device Manager all cards are gtx 1060’s i’m new to this so maybe someone has any suggestions?

Why do you need 2 threads on this?

Didn’t post the first one in the support section and can’t delete the old one

Have you updated your mobo to the latest bio’s version?
The card that will not show in device manager, have you tried just that card in the pcie slot (solo)? does it work solo?

If yes to both then:

Do you have a spare riser to make sure it’s not a bad riser?

if it’s not a bad riser, did you enable 4g?

I don’t even have the 4G option in my BIOS

I don’t think the issue is 4G as that’s normally only required for 4 cards or more. That being said, it may not even have that name in your BIOS. It’s been known to be called other things as well.

I would recommend trying the other things mentioned by @CitricAcid as well. You won’t know where the issue truly lies until you’ve done some troubleshooting. Here are some things to try in bullet form to make it easier to read:

Some things to note before hand: Are the risers powered? Do you have power to all the risers as well as to each GPU? Is your BIOS up to date?

  • Try each GPU individually connected directly to the motherboard. No risers or more than one GPU at a time.
  • If each card works fine, try connecting 2 GPU’s. One to the motherboard and the other with a riser.
  • If both of those work, try adding the 3rd GPU and see if it shows up.
  • Each GPU works when they are plugged individually
  • When I connect one gpu to a riser another one to a motherboard i still see 2 gpu’s so this option is still working
  • I Plug the 3rd gpu with any riser that i test (all are working) to a 4x slot it doesn’t show up anywhere

your BIOS is pretty limited. No option to specify PCI-E slot type (gen1, gen2, etc) either and no 4G option as with other MBs. Only two options related to GPU I could find are those:
-Dual GPU - set to ON
-Specifying primary video - set to PCI-E

Disable from bios all integrated devices that are not needed. i.e. audio, usb, serial port etc.

by the way, what is the AMD CPU that you got into that MB? that can be a limiting factor in some situations.

If nothing works, may be worth reaching out to Asrock support and ask about having 3 GPUs.

I have this CPU: AMD APU A4-6300, Dual Core, 3.70GHz, 1MB, FM2, 32nm, 65W

By the way i’m on Windows 10

not sure if this would help or you already tried it, but

in BIOS set
Primary Graphics Adapter - PCI-Express
Dual Graphics to ON

-Try procedure on page30 of the manual guide (FM2A88M%20Extreme4+.pdf) on asrock site. Seems for ATI if I am not mistaken but you can try for Nvidia - i.e. involves installing cards one first, then the rest. If you have not tried already.
-See if BIOS is latest.
-Email Asrock support to ask them about having 3 GPUs.

FM+ Socket
"There are 3 PCI Express cores: one 2 ×16 core and two 5 ×8 cores, for a total of 64 lanes. There are 8 configurable ports, which can be divided into 2 groups:
Gfx-group: contains 2 ×8 ports. Each port can be limited to lower link widths for applications that require fewer lanes. Additionally, the two ports can be combined to create a single ×16 link.
GPP-group: contains 1 ×4 UMI and 5 General Purpose Ports (GPP)."

May be that explains why you cant use 3rd GPU in the small (3rd) PCI-E slot.

Go enable the two options I suggested and disable anything you don`t use from the BIOS - serial ports, usb, audio, etc.
If it does not detect the card then pretty much its probably limitation on the hardware you have (MB+AMD CPU).
No other ideas.

It is a good MB and CPU for desktop PC , but anywhere I looked only “dual” GPU is mentioned as perk. It may just not be the most suitable combination for multiple GPUs.