Cannot restore old wallet with Private Keys. App is not loading

Application: Latest zecwalletfullnode
Daemon: zcashd v5.3.0 node!

Hi Guys, I have been trying to figure this out on my own but I’ve had no luck. Been trying since last September on and off. Not in a rush to sell no coins hence my patience.

My problem stems from the fact that the application does not load.

I launch the full wallet but it tells me i need to “Error: Error invoking remote method ‘doRPC_IPC’: NO_CONNECTION” > I used to resolve this by loading the zcashD first and then running the application. I managed tod o this once a couple of months ago and get the application running but then couldn’t restore wallet with my keys

However now when I try to sync my wallet and i run the zcashd I get the below message in the command client module, Which doesn’t make sense considering i am running the latest version anyway.

Error: This version has been deprecated as of block height 1978924. You should upgrade to the latest version of Zcash

So what is happening now is I cannot load the zecallet app because the zcashd cannot fully sync ( I think) Because when i load the app and zcashd the zcashwallet fullnode app says “waiting for zcashd to load” and once Zcashd gives the above error ZcashD closes down and the full node displays the “Error invoking the remote method” ( full error listed above).

2nd issue
my exported private keys notepad has over 300 lines of keys is this normal?

Am i allowed to post an example format of the notepad file with the keys? by pasting the first 8lines and changing the characters?

Thank you for reading. I look forward to a Zcash future and your responses :slight_smile:

You need the latest version of Zecwallet, which you can get from here: Releases · ZcashFoundation/zecwallet · GitHub


Thank you!

Step 1 is now resolved!

I have managed to sync and launch the application, When i run the full node it says i need to create a new wallet using the tool.

I have imported my private key but nothing after about 12 hours. Do i have to make a new wallet first?

1 Like

Yes, you need to create a new wallet first, which will let you backup the seed phrase. You can import the keys after.

Note that the import can take a very long time, as it has to rescan the whole blockchain.


Downloading the whole blockchain will likely take a few days

1 Like

When I create the new wallet and it asks me to verify the words from the list. After entering the 3rd one it (cl window) just closes and doesn’t give a message.

When I run the zecwallet full node i still get the “No accounts” message. Any pointers? I Can definitely see a file in the export directory with the names i entered in the wallet tool.

1 Like

Any ideas @adityapk00 ?

What operating system is this on?

Windows 10 home
Version 21H2
OS Build: 19044.2604

1 Like

Here’s what I would do:

  1. Download the latest Zecwallet Fullnode (Releases · ZcashFoundation/zecwallet · GitHub)
  2. Run the zcashd.exe daemon and let it complete for a while. This will take hours or days
  3. Start Zecwallet and import your keys.
1 Like

Thank you. I’ve done all steps.

Imported my “Secret extended key” now just waiting. Will this take about the same time as it would to sync the block chain?

Shouldn’t it atleast give an indication of the progress of the import?

1 Like

Rescan takes a while though not quite as long as a full sync or reindex


While there is no visual indication, you can tail the log file and see the rescanning progress.