Need help with fullnode wallet 0.9.21

Hi, the Zcashd wallet won’t start and states to check the debug file, this the error;

Error: This version has been deprecated as of block height 1031024. You should upgrade to the latest version of Zcash

This is the latest wallet on Github, any suggestions?
Thanks

1 Like

Can you make sure you have the latest release? Please download v0.9.22 from www.zecwallet.co/fullnode.html

Also, are you running an external zcashd? Please make sure you’re shutting down any external zcashd instances, so that you’re running the latest zcashd.

I confirm the problem with the latest version, the wallet does not start and suggests looking at the error file. (win7 64)

Can you open a command window and run zcashd.exe --version to check the version of zcashd?

It is usually located in <Installation directory>\Zecwallet\resources\bin\win

Hi, okay I’ll download the newer version from the link.
I’m unable to get the version from CMD but in Properties it states 0.9.21
I downloaded it from the Github link from the main z.cash site.

Version 0.9.21 does not work, version 0.9.20 works. I see a new version 0.9.22.

The newer 0.9.22 doesn’t work, same problem.
I’ll try 0.9.20
Btw, yes I am running win7 64

As answered below, the new version does not work, the latest working version is 0.9.20 for win 7 64. I can throw off debug.log but it is not generated when 0.9.22 is launched, although the wallet refers to it to get acquainted with the problem.

You were correct Anton1, v 0.9.20 works, thank you both for all the help. :slight_smile:

While I’m glad it worked out for now, please note that even v0.9.20 will expire in 30 days. This is not Zecwallet, but zcashd that expires every few weeks, and you need to keep up to date every couple of months if you want to continue to run a full node.

I see, thanks for letting me know.
Really appreciate the help.

Of course, you can just run a light wallet if you don’t want to update every few weeks. Get it from www.Zecwallet.co and send all your funds into your Zecwallet lite wallet.

Yeah I did download the lite wallet the other day but I’m trying to keep the full node running.
I’ll have to shift if to another station with Win10, I can’t upgrade the OS on this station.

1 Like

Can we expect a working zcashd wallet for win7?

Sorry, I don’t think I will be able to fix it. Windows 7 is no longer supported by Microsoft, so I can’t even get a copy of it to debug.

You’ll have to upgrade to a newer version of Windows or Mac/Linux

I tried running ZecWallet fullnode in a fresh Windows 7 SP1 x64 VM, and ZecWallet said it could not start zcashd. So I went and launched resources\bin\win\zcashd.exe manually and got the following:
Entry Point Not Found - The procedure entry point _create_locale could not be located in the dynamic link library msvcrt.dll.

Some googling would lead to think this is an issue that got reported for MinGW ([Mingw-users] libmsvcrt.a and _create_locale in win7), and fixed in recent MinGW: [Mingw-w64-public] [PATCH] crt: Add compatibility wrappers for _create_locale and _free_locale in msvcrt.dll . There is also a third-party fix discussion (Fixes recently introduced error with _create_locale and msvcrt), if upgrading MinGW is not an option. Maybe one of those work?

Windows 7 is still widely used in many parts of the world, and e.g. Windows 7 POSReady is still under extended support from Microsoft. Microsoft also publishes free virtual machine images (for testing Internet Explorer), if you don’t have the ISOs around anymore.

There are multiple issues with mingw / cross compile to windows. Here’s another issue that’s preventing the use of the same build environment as last time: https://github.com/zcash/zcash/issues/4848#issuecomment-724987572

Many Win7 devices can upgrade to 10 with the Win7 key in the media creation when it asks for the win10 product key, this is what did for a couple of mine (you used to be able to at least). This article was updated a week ago so hopefully still works

Thank you for your Dockerfile, @adityapk00! I can confirm that by bumping up the Ubuntu version from ubuntu:18.04 to ubuntu:20.04 the compilation succeeds and the resulting zcashd.exe (compiled from v4.1.1 git checkout) works fine under Windows 7 Enterprise SP1.

I trimmed the package imports to just apt install -y git build-essential curl g++-mingw-w64-x86-64 gcc-mingw-w64-x86-64 libtinfo5 automake libtool bsdmainutils, as the rest seemed to be implied in Ubuntu 20.04 (I guess they renamed python-zmq to python3-zmq in the Python 3 transition but my compilation succeeded even without that…) Are the others necessary/enable features? I noticed that zcashd.exe terminal output did not show the ANSI art logo and maybe that’s enabled by ncurses. Will try to investigate in a bit…

FWIW, compilation under Ubuntu 20.10 fails, as it seems to have a strict tar implementation (clang’s tar.xz archive packs symlinks (e.g. lib/liblldb.so) before the corresponding files (e.g. lib/liblldb.so.8.0.0) so the un-tar-ing step fails with "Cannot change mode to rwxrwxr-x" after tar tries to chmod a bunch of dangling symlinks. But 20.04 is the most stable LTS, and 20.10 was released just last month, so maybe that’s expected.

I have older hardware (esp. laptops) laying around that run Windows 7 just fine and would make for good self-sovereignty ZecWallet full nodes, but Windows 10 (which I have a license for) is simply too slow :frowning: Plus, peer cryptocurrencies like Bitcoin or Monero run fine on Windows 7, so it would be great if ZecWallet could too!

5 Likes

Thanks! It would be great to restore performance on these machines. At a minimum, this will help to save a certain number of working nodes. We need to keep in mind that a well-developed network of nodes is a fundamental aspect of coin stability.

1 Like