Zcash Wallet Fullnode - zcashd stopped working message

I have been trouble shooting this for over a year now and periodically come back to it believing that some will work.

I have zcash on a shielded address on the Zcash Full Node Wallet software. I want to get it off of the wallet - in whatever way possible. I believe I can benefit the Zcash community by saying this is the worst wallet software I have dealt with - you guys need to get this right. That said I love the mission of Zcash and hope all this works out in the long run.

I have downloaded the most recent software 1.7.2 and reindexed zcashd.

when I attempt to send all of the Zcash from my shielded address to a transparent address I get the below message:

I have dumped the secret-extended-key and it is not compatible with the Exodus wallet (perhaps there is another wallet that will work?)

Please just help me recover these funds. I have spent so much time reindexing and downloading new versions.

You could try Zwallet. It is a light wallet (you won’t have to download the full blockchain) and it is the only one that allows you to create an account from secret-key.

Disclaimer: I am its author.

Here was another post with the same (well, similiar) problem, I’m assuming they just ran zcashd manually and then started zecwallet but not sure, they don’t specify though they said it worked. The daemon configuration may be preventing it from starting.

The docs but basically says the same thing
https://docs.zecwallet.co/troubleshooting/#common-error-messages
But like hanh mentioned, there are other methods too

To run manually
"
NOTE: The following commands assume a default installation using the Windows Installer Method (MSI Install File). If using the ZIP version, the path should be changed to the location of where the files were extracted.

  1. Close Zecwallet Fullnode.
  2. Run the following Command (Windows Key + R)
    %LOCALAPPDATA%\Programs\zecwallet\resources\bin\win\zcashd.exe -reindex

*You may open ZecWallet FullNode at this time to see any updates or changes.

It will take time to process the changes, but when done, I am not sure if closing ZecWallet Full Node will close zcashd.exe properly. To do this, run the following command:

%LOCALAPPDATA%\Programs\zecwallet\resources\bin\win\zcash-cli.exe stop
"

As you can see it has the -reindex flag so if you dont want to begin immediately (shouldn’t wait too long) then just remove it.

1 Like

Is it open-sourced?

1 Like

If these fail, you could try a few other things:
Windows likes to disable and/or prevent the zcashd process from communicating with outside world for security reasons. In the past I’ve had to ‘bless’ zcashd so windows would allow it to run and communicate through the firewall.

1 ) Allow zcashd to communicate through firewall:
In Windows search bar type Allow an App through Windows Firewall (or copy/paste this text)
Then click [Change Settings] button.
Click on [Allow another app] button, [Browse] then paste %LOCALAPPDATA%\Programs\zecwallet\resources\bin\win followed by the [Enter] key.

You should see two exe files, zcashd and zcash-cli in the file dialog. Click zcashd, and in the dialog named Add an App, you should now see zcash in the Apps listbox. If so, click [Add] button.
You should now be back to Allow apps to communicate window, make sure the Private checkbox is ticked for zcashd, then click [OK] button.


2 ) Now zcashd should be allowed to communicate, we need to make sure Windows isn’t killing it. A quick way to test this is to temporarily turn off ‘Controlled Folder Access’ and start up zcashd

In search bar, type CMD, then make sure to ‘Run as Administrator’.
In the DOS window, paste %LOCALAPPDATA%\Programs\zecwallet\resources\bin\win via [Shift] + [Insert] keys or right click your mouse at the prompt, followed by [Enter].

Watch this, if zcashd doesn’t terminate, then you know Windows normally halts zcashd, and you’ll have to ‘bless’ it.
Follow the instructions on this page:
How to manually allow a blocked file or app in Windows Security (thewindowsclub.com)


Finally, there is another command line switch you could try besides reindex, that’s rescan.
zcashd -rescan

Hope this helps,
Zec Prophet

1 Like