Can't access ZCL wallet, nor import into YWallet (too many shielded)

I’ve been using Zecwallet Lite on mac OS for a long time, and recently - as I’m sure many know - the network has been struggling. I am now unable to access my wallet at all: it gets hung on the “setting things up” screen before I can see my wallets/balances or change any of the settings.

I have my seed phrase, so I was told to import it into ywallet. While the wallet(s) open in Ywallet, they all show 0 balances. This could be because I have a lot of shielded addresses (I added >20 “sub-accounts” in y-wallet just to be sure) OR because there’s a mismatch between the wallet addresses that ywallet is loaded and the wallet addresses that are in my ZCL wallet. I unfortunately can’t confirm this, because I as described above, I can’t access my ZCL wallet.

At this point, I’m entirely stuck and don’t know what to do to get ahold of my funds again. My first point of call IF I can get into the correct Shielded wallet (that holds the balance), is to transfer the funds to a fresh wallet and start from scratch. Please help!

Presuming you’re using the latest version, did you select Zcash in the settings? It defaults to Ycash otherwise and handles both.
If so, does it sync or are you fully syncd? It’ll indicate if it is or not and shouldn’t take long to start up and complete, the eta may or may not populate.
If not, try changing the server. In settings you will see lightwalletd (default), zecwallet (try this one), and custom, be sure to select :ballot_box_with_check: ok. There are other lightwallet servers listed round here as well (free2z Ive seen recently).

Yes, I selected ZCash in the settings.

It took a few hours, but yes, it is fully synced.

I am currently using the zecwallet server.

So I’ve tried all those troubleshooting steps already.

Hahn posted a video describing how to recently, I’ll find it, not sure if itll help though

I’m pretty sure this is the video I tried. He actually directed me to this forum and said I need to be able to know what the addresses were of my wallets within the ZCL client first to confirm that it’s matching to what’s in YWallet.

1 Like

I’d first just import the seed phrase in Ywallet and do a complete rescan. If that address has some history, chances are high that it is the right seed.

yea, good call to check the history. so i DO see history in my primary wallet within ywallet. but neither that nor the 30 sub-accounts show any balance.

however, it seems like that history is from my transparent address, not the shielded one. the shielded wallets are where my funds are. not sure if that helps.

Well - some screenshots would help

what do you need to see? it just shows a bunch of addresses with 0 balance

Do a screen recording of going through the tabs and accounts. Just need to a do a couple.

  • account page: shielded + transparent
  • account manager page
  • tx history
  • notes

Feel free to dm stuff if you feel necessary ya know thats ok

btw, i have over 35 shielded addresses…

OP could import his addresses in YWallet but it turns out he still has more. He’s adding more sub-accounts and rescanning now.

Edit: Fully rescanned a wallet with 100 shielded addresses in 1h40 on PC. It is slow but it will get there.


This issue is resolved. Big thank you to @hanh.


  1. export wallet.zwl from ZCL wallet
  2. create fresh install of ywallet
  3. restore wallet.zwl into ywallet
  4. re-scan

Congrats on getting your funds back.

For the record, @zeecashzee 's wallet had 98 shielded addresses. They were all imported and rescanned in one go by ywallet in about a couple of hours.


98 is record for sure