Computer crashes with above 4g memory/cryptocurrency mining enabled; Windows and Linux won't recognize all my GPUs

I’m quite tired, because I have no clue of what else I need to try to see if my rig will finally work as intended.

I have 5 graphics cards: 2 RX 480 and 3 RX 470. Some (2 RX 470) are with the BIOS modded, some not.

Regardless of enabling the aforementioned setting or not, I’m unable to have my rig fully working (that is, with all my GPUs being recognized), with the difference that with the above 4g thing Windows 10 won’t even boot and my PC crashes completely, with lots of artefacts.

I’m using the newest drivers, Windows 10 64 bit, motherboard MSI Gaming Pro Carbon, 8GB RAM and USB powered risers. I have tried with both a SSD and an used SATA HDD, with no success. Please somebody help me out, because I’m extremely confused/upset/sad/etc… I have wasted a lot of hours trying to make it work. Cheers!

First issue, you are using the wrong drivers
Second, have you updated your bio’s to the latest version?

3 cards 4g off, 4= 4g on

Wrong drivers? Claymore recommends the latest version for Polaris cards,
not to mention that, as I said, above 4g makes the PC crash BEFORE Windows
even loads (in other words, it’s a BIOS crash issue, therefore the drivers
being used aren’t relevant). Second, yes, my BIOS was updated to the latest

No sir you are mistaken… For 4xx cards (Polaris) Crimson 16.12.2 is recommended

1 Like

Huh, ok, you are right, if you meant ONLY Zcash, although it has NOTHING to do with drivers, because I can’t even boot to Windows when above 4g is enabled. You aren’t very tech savvy, it seems…

I said earlier that I get artefacts with this setting enabled, however I’m
getting a stuck black screen with the used SATA HDD. I don’t think I’m
having a good progress with this, though…

I think I figured out why I’m having this issue: I need to have Windows as UEFI instead of MBR to have more than 4 GPUs working, it seems. I will try it later.

actually you dont know for sure it has nothing to do with drivers, because windows uses the drivers to load… and if its not loading it could be drivers
could also be your modded bios
could also be a bad GPU
those are my first guesses

4g does depend on drivers, so if its not loading it is probably related to the drivers somehow

you cant do 4g enabled without drivers…

I’m facing issues not only with Windows, but also with Linux Mint. Please note that my PC crashes right before GRUB appears (I have Windows 10 and Linux Mint installed).

If it were due to a modded BIOS and/or a bad GPU (they are all brand new), or even drivers, I wouldn’t have this very same issue even with no graphics card attached at all, right? Above 4g setting crashes even when no GPU is attached!

But since you guys are still obsessed with drivers: yes, I’m using the recommended drivers!

how can you use above 4g without a GPU?!?!?!
there is no way it can boot with 4g enabled without a GPU… 4G requires a 3d capable video card.

Not sure about linux, have not installed linux YET on a board with 4g, but that will probably change in a day or so.

@acaciosc you asked for help, help is trying to be provided. This is the “Zcash forums” which means any help you ask for is more than likely in reference to mining zec.
It had to be pointed out twice that you were using the wrong drivers for the 4xx series cards, and not until I posted a link backing it up did you accept it. We are not obsessed with drivers but when you are using the incorrect ones, it will not mine correctly and it could cause loading issues.
As for the tech savvy comment, I’ve been working on and with computers, software, and etc since DOS 2.1, I could tell you that I am the CTO, that I have DHS clearance, along with several other things that would probably mean nothing to you other than along with the probability that I have probably forgotten more tech than you have learned.

There are a lot of people on these forums, several knowledgeable people attempt to help others out when others have issues, questions, etc. It is never a good idea to criticize or attack those that are helping you, especially someone like @cryptomined whom MANY consider an expert in this area, because I know I consider him one and a true asset. When you say “you are not very tech savvy” to me, or accuse both of us of being obsessed with drivers, when all I was attempting to do was offer help, it seems very unappreciated.

As @cryptomined pointed out and I pointed out in my first response to you that 4g off with 3 gpu’s and 4g on with 4 or more gpu’s. If you are not running ANY gpu’s this = 3 or less so 4g should be off.

For the last piece of advice I will give you, You need to reset/ start over with gpu’s that are stock (not modded), the correct drivers with the mining software you are using, doing “one” card at a time, if one works try two, and etc.


Huh, now I know why your nickname is called “CitricAcid”: you like to troll a lot, don’t you?

When I said you don’t seem to be tech savvy, it was just a finding, because I clearly stated that I’m not even able to boot into Windows, but you still recommend me to download a recommended driver. I did it and guess what?! Heck, yes! Didn’t work! What now? Upgrade Windows for the latest version? That is sarcasm, if you didn’t notice.

You may have a nice curriculum, but hey, here is not the place for you to show off, neither does having a good diploma make you invulnerable to ignorance. What you are doing is called “argumentum ad verecundiam”.

Finally, as for the above 4g thing, it crashes regardless of having 0, 1, 2, 3, 4 or 5 graphics cards…

What I got it to partially work (the GRUB still won’t show and there are artefacts) and be able to load Windows and start mining is by using IGP as primary display. The problem is that I still face issues of not having ALL graphics cards detected, randomly showing 3 or 2 graphics cards, usually. For example, right now I’m able to mine with only 1 RX 480 and 2 RX 470, although I have plugged in 1 RX 480 and 3 RX 470. I would like to invest even more in mining rigs, but it’s not as easy as it seemed… THREE sata to molex got the 12v wire burned - the risers are version 003, and since you have some technical knowledge - right? -, can you confirm me if it’s recommended to use only version 007? I think the 12v wire had to be thicker.

Start over with stock cards or just one moded. Try to make it on Ubuntu following tutorial on google - ubuntu zcash mining. Install everything with only one GPU connected or better without any GPU, just use the VGA on the board. Then, like CitricAcid advice, put one by one the GPUs and more important make it easy :slight_smile:

It crashes even with multiple GPUs… except if I set IGP as primary, but in this case I won’t have GPU control (temperature, fan speed, etc.) and it’s shown artefacts in the BIOS part and the GRUB doesn’t even show up. And the most important matter: I’m still unable to have all my graphics cards detected.

I don’t want to use Ubuntu for mining anymore because it’s a pain in the b*** to install graphics card drivers, especially after AMD dropped support for Linux. Not to mention that there is no Nicehash software for it.

Anyway, I have Linux Mint already installed and it’s shown only two graphics cards even though I have 4 plugged in (most probably due to not having above 4g enabled, nothing to do with OS or drivers).

I regret that I am unable to assist or recommend to you any additional information.
Good luck!

1 Like

No problem and thank you for wishing me good luck.

you seem to know what its not, so I think you should be able to figure it out yourself.

Dude, you are being caustic. Your not going to get much help on the forums treating people like that. Especially when its the key people who can really help you out. I get where you are at, I have wanted to pour gasoline all over a rig, piss on it, and light it on fire more times than I care to remember… But does not help your situation taking that out on people who can help you. Try again, give people the respect they deserve, and you may get a solution to your problem.


Hmm, so you accuse people of what you are. Interesting… get out of here with this childish reply!

1 Like

Indeed… I discovered on my own. It was due to having Windows installed in a MBR partition instead of GPT. Thank you, anyway…

1 Like

Thank you for understanding me. I indeed was to the point of smashing all my rigs, lol.

I got upset that the replies I had received so far were all nothing to do with my issue and I knew they wouldn’t be useful, but yeah, I think I needed to calm down a little more before answering them.

1 Like