.CONF "swap file" problem


#1

I'm pretty "new" when it comes to this stuff, so bear with me.

I entered the command vi ~/.zcash/zcash.conf so I could create the Zcash.conf file, but I screwed something up. Then, apparently, I further complicated the problem by "x-ing" out of the terminal instead of quiting with the correct command.

At this point, I just want to start over (create the .conf and enter testnet details) but whenever I enter vi ~/.zcash/zcash.conf I get the error below. I'm not sure how to fix this problem. I'm guessing somebody here can fix it in 5 minutes, so it makes more sense for me to break down and ask, rather than spend another couple hours trying to figure it out.

Link to Screenshot of error


#2

Rather than doing it by command line you could look in your files directory, CTRL+H to see hidden files (.zcash) and right click to create the .conf file (inside the .zcash folder)


#3

Thanks for the fast reply, Shawn. Quick question: I see the two files that were showing up in the error message (the most recent screenshot only shows one of them, but there were two) Anyway, they're named: zcash.conf.swp and zcash.conf.swo. ...would it hurt to delete those?

UPDATE: Ok, I deleted the two files and I seemed to get a little further, but I'm having no luck when I go to save the testnet info. Here's what I'm doing:

I open terminal and enter: vi ~/.zcash/zcash.conf

I then press "insert" on my keyboard and paste in the info
testnet=1
addnode=alphatestnet.z.cash
rpcuser=username
rpcpassword=password

I then press ESC and enter :wq then press "enter"

I get the error "can't open file for writing" (screenshot below)
Screenshot image

By the way, I did try adding zcash.conf manually to each of the three zcash folders I saw in the directory (I just put "test text 1, test text 2, test text 3" respectively in each file) but I didn't see any of these in the terminal when I ran the command vi ~/.zcash/zcash.conf (...not sure, but I think if I'd added the file to the right place, I would have seen one of the test / text messages.)


#4

Check that the ~/.zcash directory exists and has permissions allowing writing by the user account in which you're running vi.


#5

Would I just search for .zcash ? If so, I don't see anything coming up with that name. I only get results when I search zcash (without the dot).


#6

There is a zcash directory & .zcash directory. I think you might find this easier with a desktop interface btw. What OS are you using?


#7

I'm using Ubuntu 16.04 64 bit (was told that was the one to go with.) I don't see the .zcash directory. Easy fix? (Fingers crossed).

NOTE: I do get ".zcash-params," but I'm guessing that's not what I want.


#8

This command will show all the files and directories in the current directory:

ls -a

If you see the zcash directory but there's still no .zcash directory then you might not have followed all the instructions in the Public Alpha Guide - particularly the fetch-params.sh part.


#9

Well, it's definitely not there. (I've done this on two machines, the other one has the .zcash directory...this one doesn't.) No idea what I did wrong / different. Here's what I ran before...should I just run it all again?

git clone https://github.com/zcash/zcash.git
cd zcash/
git checkout zc.v0.11.2.z8
./zcutil/fetch-params.sh


#10

Did fetch-params.sh take a while to finish downloading the proving key? Did it show a progress display?


#11

Note that you should now be using git checkout zc.v0.11.2.z9. You also need to create the .zcash directory using mkdir ~/.zcash (the Public Alpha Guide does say this).


#12

Yes, everything took a while and I ran the "tests" afterword (which also took a while but seemed OK.)


#13

Thanks, Daira. I had another guy who knows a lot more about this stuff than I do write out some instructions for me...seems like they worked on my Windows 7 machine, but not my Windows 8.1.

Am I able to fix whatever is screwed up here, or do I have to uninstall and start over?


#14

Starting in the same directory that the zcash directory is located, what happens when you enter?

ls .zcash

The reason I ask is that fetch-params.sh downloads files into .zcash


#15

When I open the terminal and run that command, it just says "no such file or directory."

Here is the full view (what I get when I run ls -a

.Zcash missing


#16

I updated https://github.com/zcash/zcash/wiki/Public-Alpha-Guide#running to hopefully make the need to create ~/.zcash clearer.

Note that zcutil/fetch-params.sh creates ~/.zcash-params, not ~/.zcash.


#17

Thanks again. What happens if I just start over from the beginning? Do I wind up with a bigger mess, or will everything just be "updated." (I'd be using your guide this time instead of the instructions I used before.)


#18

You should be able to just continue from the 'Running' section (if you've already completed the previous steps).


#19

Gave it a shot, but still got an error (screenshot below)

No luck


#20

~/.zcash/zcash.conf is not the command and it obviously produce that error message. You simply need to create a zcash.conf file with a text editor like gedit and then place it in the ~/.zcash folder.