EthOS - EWBF miner flags (and Nanopool email problem)

Hello everyone
Can someone help me with setting flags at EWBF miner in EthOS distro? iโ€™m trying to force --solver 0 and --eexit 1 but if i put it in local.conf after flags they do nothing there is still Solver: Auto when miner comes up. When i check /var/run/ethos/ewbf-zcash.conf there is no solver flag at all and when i add it and restart rig it will be overwritten :confused: any sugestions?

another thing is that i want to mine at Nanopool but i cant get my email adres to my wallet because script always add rig name at the end of proxywallet string so even if i add my worker name and email adress to the wallet i will have something like this in the end: WALLETADRESS.WORKERNAME/EMAIL.WORKERNAME(or ethos 6 digit numer)

a realy nice guy at support chanel of EthOS at IRC said he doesnt know what to do :wink: so maybe i will find help here
hope for the best!
thanks in advance

PS
sorry for bad english :slight_smile:

the settings you are looking for are in /opt/ethos/etc/ewbf-zcash.conf
command โ€”> sudo nano /opt/ethos/etc/ewbf-zcash.conf

Add a line such as this
solver 0 0 0 0 0 0 0

ctrl-o to save ctrl-x to exit r to reboot and good to go

have a look at this for the pool login info
http://ethosdistro.com/kb/#password-pools

1 Like

God bless you! or may the Force be with you! or High five from Cthulhu!

at last i forced solver 0 which gives me more stable sols/s :wink:

second problem with email adress cant be solved with that instruction (but its good for Suprnova) or im too dumb for that :slight_smile: i need that kind of string WALLET.WORKER/EMAIL :slight_smile: that email gives problems to me

Give this a try

proxywallet [wallet].[rigid]/emailaddress
proxywallet 0xAAAAAAAAAA.blabla/email@emaildomain.com

at first post i wrote that i did exacly what you suggest i have line in my local.conf which looks like:

proxywallet [wallet].RigID/myemail@gmail.com

but in the end (when i check /var/run/ethos/ewbf-zcash.conf) i see that that line is modified by EthOS and looks like:

[wallet].RigID/myemail@gmail.com.RigID

which shows that EthOS adds RigID(or worker name if you change it by command: loc RigID NewName) at the end of proxywallet string. I still dont know how to change it and i need this to have email notification when my worker goes down.

I would try to remove your rigid from your config only proxywallet addy/email

how to do that? i think RigID is written deep down it EthOS instalation and you cannot remove it entirly. So basicly EthOS will always have something to add to wallet adress

I know that but try not putting it in your config
[proxywallet [wallet]/emailaddress
worth a try

From your post it looks like it is added twice so remove one
the one in your config

but the thing is that i cant remove it :slight_smile: EthOS automaticly adds .WORKERNAME at the and of the proxywallet string so if i write:

proxywallet walletaddress.WORKERNAME/emailaddress

i will have:

walletaddress.WORKERNAME/emailaddress.WORKERNAME

and i CANT edit it :slight_smile:
i did a workaround by setting my rig name to โ€œcomโ€ :stuck_out_tongue_winking_eye: so i have:

loc xxxxxx com
proxywallet WALLETADDRESS.RIGNAME/EMAIL(without .com so gmail.com -> gmail)

and after that i got proper rig name and email address at nanopool so i have notifications and can set my payout level.

Its ugly but it works :slight_smile:

i know itโ€™s very late to offer my help but better late then never:
ethos will add rigname automatically, there is no need to put it in any config file.
Instead of that, do this:

proxywallet your_wallet
proxypool1 zec-eu1. nanopool . org:6666
proxypool2 zec-eu2. nanopool . org:6666
poolemail your_email
poolpass1 z
poolpass2 z

In the end, in your ewbf config file you will have this:
[server]
server zec-eu1. nanopool . org
port 6666
user your_wallet. rigname / youremail
pass z

[server]
server zec-eu2.nanopool.org
port 6666
user your_wallet. rigname / youremail
pass z

I had to put spaces because forum was thinking that i am posting some URLS. Please remove spaces if you copy/paste those to your config files.