EWBF miner Connection Lost

Hi, I'm having this issue where my connection is lost and it is only reset once I press enter in the cmd line.

Has anyone figured out an automatic restart solution or a process you would use to restart?

my current execution command in a .bat file is

:MINE
miner.exe --eexit 3 --pec --server --user . --pass --port 3333 --cuda_devices 0
GOTO :MINE

I assumed executing --eexit 3 would restart it. Or does it only close the cmd?. It didn't do so when I ran it.

If you could help me , it would be much appreciated!.

Thanks

I did some tests and the execution does work if I unplug my network cable. So the .bat file executes the loop as predicted.

However, it still freezes after a while even after running this bat file. So I'm unsure why it would have this anomaly. Has anyone else experienced the same issue?

post the screenshot, maybe it can help others to understand your problem

if your on windows just create a scheduled task on startup its easy

I have the same issue. I tried to switch different server, but it still sometimes happen. Please help.

same problem here

I get this a lot. I think EWBF and Zecminer. One or the other I get this issue. Not sure why. My internet is perfectly fine. Wondering if anyone has found a solution for this. It's not good.

I'm in the same boat on Windows 10 x64 with 4x 1080 ti GPU's. Everything has been working fine for 2 weeks and all of a sudden the past 2 days the EWBF Miner disconnects after 1-3 hours on version 0.3.3 or 0.3.4. It reconnects when I hit enter or right click on the window. The only log information that is remotely useful was that GPU0 turns red which I'm not sure what that means....I also noticed that even after it reconnects sometimes nanopool does not receive new shares. :frowning:

I found a script from another user that when the miner has issues or disconnects. the Script reconnects you. However. Sometimes with this issue. It still happens. I think some of it has to do with the miner switches to the devs pool for a set time and they get paid.

I think a more reliable cuda(NVidia) zcash miner needs to be built.

Would you mind sharing the script? The odd thing is I have another machine on the same network running the same miner with gtx 1060 6gb's no issues...

Don't click inside the CMD window for EWBF's miner. It pauses the processes and that's why you get disconnected. I'd suggest once you start it simply minimize it via the taskbar and if you need to check it maximize it from there again.

I wrote this powershell script to help resolve this if internet is restored:

Hi! root, nice script, and thanks.

The problem isn't that the process exit, it hangs, the process is still running. When you hit enter it reconnects. Even if you have a connection it hangs. I have a ping-test to the server, and that tells me that the connection is fine. So weird.

The problem would be solved if you could send a "enter-keystroke" every minute or so. But i don't know how to do that. Maybe you could add that?

Found this:

$wshell = New-Object -ComObject wscript.shell;
$wshell.AppActivate('title of the application window')
Sleep 1
$wshell.SendKeys('~')

status= hanged

When i hit enter:

Hi root! Please help us!! :smile:

Let me see if this is correct:

You're overclocking and then it hangs at some point, and after pushing enter or another key it starts to work?

It wouldn't be hard to add a keystroke. You already found what I found at https://stackoverflow.com/questions/17849522/how-to-perform-keystroke-inside-powershell

I'm also curious if it hangs because one of your gpus overheated and they won't accept work until they cool down and if it's safe to force-restart. I'm not sure, but feel free to add this to my script and report back on how it works.

Good luck!

Hi!

Thanks for your answer.
Im actually not overclocking at all. And yes, when i push a key it reconnects.

Im sorry but where can i put it? Is it ok at the end?

$wshell = New-Object -ComObject wscript.shell;
$wshell.AppActivate('title of the application window')
Sleep 1
$wshell.SendKeys('~')

Big thanks!!

Hey there, @sojjan did you end up finding a solution to this? I’m having the same problem - no OC, low temps but every now and then the miner hangs. Need to press Enter to get it running again…

Cheers!

I just had the same thing happen to me 15 minutes ago. I am running 2 x 5 1070ti. One of them is connected with an ethernet cable and the other with wifi. The one with the ethernet cable got the “disconnection error”, the one with wifi did not… (weird imo)

I just restarted the miner and it seems to run fine, but I will be monitoring it closely in the next few days.

Perhaps it was an error on the pools side?

Anyways, I hope we can get over this issue :wink:

Edit: By the way on which servers did u experience this error? I got it just now on eu1.

Hi. Yes it is working for me now. The thing i did was that when i start the job i didnt klick with the mouse in the window at all, or even push enter. Just started the ewbf and let it be.