Ewbf's miner kills network connection

Hey Guys,

I started mining using ewbf’s miner 0.3.4b 2 Days ago, before that I was mining ethereum unsing ethminer. My Hardware Setup is asus z170-a mainboard with an i7-7600k and a zotac gtx 1070 amp! extreme.
When ever I run the miner, it kills the network connection after some time (probably hours), I need to restart the PC, then it’s on again. Windows 10 reports a lost internet connection, sometimes switches to no network attached. I’m using the built in LAN controller and never faced this issue before.
I have this issue on both PC I’m mining on (both have the same setup), but it doesn’t kill my network. When only one PC was mining (showing no network connection now) the other PC still can acces the internet.

I don’t know how to analyze the problem, any suggestions from you?

Thank you in advance,

Hello Autchirion,

From my network experience and knowledge the miner should create only one ESTABLISHED connection.You could see that by running as administrator rights in cmd :

C:\WINDOWS\system32>netstat -ban | findstr :3072

findstr :3072 in my case will search for TCP connection on custom port 3072,in your case could be different.

I don’t really think this could strarving the bandwith.Maybe is driver issue or something else.My advice is: first list your TCP connections and go from there.Good luck on your findings :slight_smile:

Best regards,

1 Like

thank you for your ideas!

Command gives:

So, connection is established, but right now I can’t see how this helps me, because as soon the connection to the network crashes this won’t be there. I checked if there is a new driver available, but unfortunately it isn’t. Is it possible to log what lead to the crash?

I just deactivated the low power mode for my network device, I hope this helps.

One PC was not updated to the latest driver, after I did this and deactivated the Power Saving mode everything works fine.

after a couple of days running and I thought, that I solved the problem… I obviously didn’t, I only decreased the time to disconnect. Any suggestions how to continue?

Easiest fix would maybe to try and get a wireless USB stick and see if running off wifi solves the issue.

I had the same problem in the past with my Biostar BTC250 board and it turned out that the PSU was the issue. Somehow drawing more power from the PSU causes the ethernet port to have issues. Do you have another PSU you could test with?

Good luck!

That’s a good Idea, actually I’ve got a wifi Stick at home, so I can try this.
What is weird about that, before The Windows 10 update to version 1709 (fall creators update) the PC never showed this behavior while using ewbf, but I didn’t mine for a long time with that so probably it just never occured.

Unfortunately I don’t have a different PSU to test with. But I’ll think about buying one to test it, does ewbf miner lead to more power drain than ethminer (I used that before)?

Short update, I got a different PSU (850W instead of 550W, but same manufacturer) which didn’t solve the issue, still facing random crashes of the network connection.
WiFi Stick is installed, except one crash of the miner this morning, the system is mining since 2 days without any connectivity issues. So it’s somehow connected to the on-board network device.

Next steps:
-check if the network chip might overheat
-check if it also happens while ethereum mining (worked well with ethereum)
-run wireshark to get some data if there might be a package messing with the network chip

-no overheat detected
-ethereum mining works
-didn’t see weird stuff in wireshark

I don’t know where to continue, any ideas?

Even I had this problem. This guide resolved the issue.



thank you for your answer, appreciate it! Unfortunately for me it’s the other way around, not WiFi get’s lost, but my cable network connection. Unfortunately I already followed all these ideas, so right now I’m just not using EWBF any more, but a different miner.

I had this problem too with linux version of EWBF miner and some Netis Wifi AP … with ZyXel AP works all ok

Go back into the power profile and select the network adapter and make sure its not set to allow it to turn off to save power. Windows 10 is inherently crap I have dual boot and mine coin on 7 always.10 causes issue after issue and it basically just a spy network on your computer.

also this didn’t help :-/