Help, Won't boot into linux after adding the 6th card

I am using Ubuntu 16.04 LTS with an i5-5600 and a Gigabyte GA-Z170X-Gaming 3 mobo with 16 gb ram.

I ran on 5x MSI RX 480 4gb for a few weeks with no problems. One gpu is into PCIE slot 1 and the rest are on risers. I decided to add the six one and now I can't get ubuntu to load. This is my dmesg error.

Has anyone ran into this problem before?

Thanks,

Z170 chipset is a disaster. you're lucky to even get 5 cards. you need the Z97.

Could a bios upgrade help?

I thought and tried the same.. turns out no. Although in theory, the OEM could provide you a very custom BIOS to make it work, but probably at the expense of disabling other stuff on the board. I wouldn't ask let alone hold your breath. Basically the issue is that the PCI lanes are crowded with other "stuff", devices, SATA, USB, etc and there is just no more room. Here's an email I got from tech support at Asus about my Sabertooth Z170 S mobo (which I managed to only get 3 GPUs with):

We are writing back to you regarding the issue with your motherboard.
I checked and found that the system has not enough resources because 6th generation processor and chipset has only 16 PCI lanes access or 32GB/s.
_If you are using 6 graphics card on these specifications: _
2 x PCIe 3.0/2.0 x16 (x16 or dual x8) = 16GB/s or dual 8GB/s + 8GB/s
1 x PCIe 3.0/2.0 x16 (max at x4 mode) *1 = 4GB/s
3 x PCIe 3.0/2.0 x1 = 1GB/s
You can only use function 3 graphics card because of that. Furthermore, the system needs bandwidth on SATA ports and USB, so it will also share with 32GB/s or 16 lanes.

btw you can try disabling various devices in the BIOS (audio, etc) which some people have said helped them on Z170 (it didn't work for me) but I doubt you'll get all 6 GPUs. If you do though, let us know. In the meantime cut your losses and get a different board or settle for 5 GPUs. Oh and one last thing, I RMA'd one of the Z170 boards I tried on the basis that it is broken - which it is, from a consumer perspective. Regarding the other Z170 I tried, I just decided to keep it and build a new gaming rig with it. :slight_smile:

I looked around the BIOS and disabled the internal gfx to help. Still no luck. I am wondering if I ran all my GPUs on risers if that would help. Gonna try it.

I don't think the risers are your problem or solution

mine works fine with 8 gpu"s you need a pcie switch