6 GPUs MSI x370

I have an MSI x370 wih a ryzen and it works fine. When I have 5 GPUs it works fine. I added an add2psu and a second psu. When I try with the second PSU it won't boot or won't recognize the gpus on the second psu. I am not sure what I am missing. Any advice?

Windows 10 with updated drivers?

Windows 10. Updates drivers.

I went to bios and disabled hd audio. Now it crashes once windows loads. So I removed drivers. Now it loads windows however crashes installing drivers.

Trying with 5 again. If these drivers crash also I am going to re-install as something is very broken.

OK drivers installed with 5 cards and worked perfectly.
6 Cards don't work, drivers crash.However windows does work.

I can't find anyway to set PEG0 and PEG1 to Gen1, also i don't see anywhere for above 4G decoding. :frowning:

Have you tried moving 6th riser to a different slot? It could be a bad riser.

I had extra risers so i actually swapped some of the risers out, and changed which card was in which slot as well. It works perfectly with any 5, but not with 6.

I know with my RX machines there was an update that caused them to stop running with 6 gpu's. My solution, it might be many others too, was to reload the OS (clean), video drivers and not do any updates. All of my cards are working fine. I dont know if this would work for you or not but it couldn't hurt.

Another possible solution could be to load Ubuntu on a spare drive with video drivers and see if all 6 are recognized. That would let you know if it's an Widows thing.

I will try a fresh windows install in the near future. I think i can do that faster than figuring out how to overclock and under volt in Linux.

i tried a fresh windows install.
same behaviour.

I have it running 5 again now. I might try a linux distro when i have more time again.

I had to install Windows via UEFI rather than the traditional MBR installation of windows to get the 6th card to be detected. Google rufus USB tool and use that to create a windows boot USB that will install via UEFI and you should be good to go!

I used UEFI. Didn't make a difference.

You definitely used a UEFI install? The only reason I'm saying this is because you pretty much have to intentionally install it a specific way to do so.

For defence this has nothing to do with a UEFI bios.

Yes I am sure. Also I got it working on a different board. It's definitely
the board itself.

1 Like

Hey, man, I dont know if you got it working, and I don’t like necro posting but I think this info is useful to be outthere and if you didn’t get it to work already, this is what I did…
System: AMD Ryzen 7 1700
MSI X370 SLI Plus with latest mobo firmware
6x ASUS Strix GTX 1070 non-OC version but OCed (Mem clock @ 8733 Mhz)
Corsair 8Gb 3200 Mhz RAM
PSU Seasonic X-850 Watts 80+ Gold x2 (3 GPUs on each PSU), second PSU with metal clip power-on method.
Windows 10 Pro updated to latest everything

A little history first:
I tried every combination of slots and risers, they all work independently and up to 5 GPUs using the latest Nvidia driver (384.94) with Windows 10 booting up and hashing Zcash with EBWF with no problem. But no matter where I put the 6th GPU, whenever I did, Windows would not boot and would enter a loop where eventually the error repair screen appeared.
If I booted to safe mode, Windows showed the 6 GPUs on device manager, but the driver wouldn`t be loaded so u can hash with it. WHen doing a DDU driver uninstall, booting to normal mode worked and Windows would show the 6 GPUs on device manager but as Generic display cards, not being able to mine of course.
So I bought ethOS and after the initial learning curve, got all GPUs to mine but would constantly have random crashes fails that didn’t lock the GPUs but where very annoying cause I lost hours of posible mining (which translates directly in loss of revenue). Because I dindt wanted to open a port on my router to acces the rig remotely, I used Teamviewer on a second machine that mines in Windows at a very lower rate (2x GTX 980) but super f***ing stable (not a single crash ever, even on overclock, against the 2 crashes per day of ethOS, even on non-OC settings) but allowed me to acces the machine on the local network.
Still, I want to mine on Windows so that I can 1) have stable mining and 2) be able to use Teamviewer to manage the rig as if I were sitting right in front of it.
Checking the main panel on ethOS I noticed that the GPUs were listed as 21-22-23-24-26-27, missing the “25”, so I thought that the maybe the secquence of population of the pcie slots might have something to do with it.
In the mobo, the slots go from top to bottom: x1 - x16 - M.2 - x1 - x16 - x1 - x8
I bought an M.2 to PCIe x4 adapter to add a 7th GPU, because whatever…
And for some reason I thought “why not try it on Windows?”. So I set it up as following: x1 / x16 / M.2 / x1 / x16 / x8 and turned it on.
And that motherf… Windows just booted right up, loaded the OC config with GPU Tweak II and started mining like a devil at 2830-2840 Sol/s. Freaking beautiful.
So, 6 GPUs on X370 is absolutely doable.
I hope this helps others.

Later.

long story short you plugged the 6th card in m.2 instead of pci e?
Could’ve been for lanes available, maybe disabling audio and other lanes they could’ve worked… who knows?

Yeap

  1. Maybe leaving the m.2 slot unpopulated when loading all other pcie slots doesn’t agree with Windows (as I said, ethOS had no problem with the 6 cards so I don’t think it’s a problem with availability of lanes on the board itself).
  2. I did do everything that was recommended for the x370 board, like disabling audio and enabling IOMMU, nothing worked for Windows. Plugin 1 card at a time or all at the same time was exactly the same for Windows, it would recognize and boot properly with only 5 GPUs tops.