I cannot send ZCash payments no matter what

Hello. I have some ZEC in my Coinomi wallet since about a year or so ago but I suddenly was not able to send ZEC anywhere anymore. So I tried importing my seed in other wallets such as Trustwallet but still no luck.

I finally decided to install Zecwallet Lite on my Windows 11 PC and I allowed the whole thing to synchronize. So far so good. But I still cannot send ZEC. Anytime I try to send ZEC anywhere, it says Step 1 of 1, and then I get this error in Zecwallet Lite:

Error: SendResponse { error_code: -26, error_message: “66: tx unpaid action limit exceeded” }

I honestly don’t know what else to try. Maybe tx fee is too low? I don’t seem able to adjust it anywhere either. Any help is appreciated. Thanks in advance.

1 Like

Well it sounds like the transaction you’re trying to make is too expensive for the old transaction fee. I don’t think that wallet supports being able to change it so you’re going to have to send smaller amounts basically. If it gave you that error then the import did work it’s just a consensus/wallet incompatibility thing

1 Like

Somewhere I read about editing some zcash.conf file but it doesnt exist in my system and creating one does not seem to change anything. In theory should have been able to set the Tx fee or something.

ZecWallet Lite does not support the new fee structures. zcash.conf is the configuration used in zcashd, the full node implementation of the Zcash protocol. zcashd does have its own wallet bundled with the node, it is a command-line interface but fully supports the new fee structure. Using the full node wallet would be one way to ensure you have the appropriate tx fees.


Yes zcashd supports all that and you can read about it in the doc man zcashd files.


OK. I will look into zcashd then

I got a zcashd binary for Windows (sorry I dont have a Linux machine at least not with the required specs)

When I try to run zcashd.exe from command line I get the error “\Roaming\ZcashParams”
Please run
‘zcash-fetch-params’ or ‘./zcutil/fetch-params.sh’ and then restart."

This is not a Linux machine and the proposed solutions seem to be aimed at Linux. Not sure what to do now.

I guess I will just give up. All I have 1.77 ZEC so I will just accept I lost these coins for good.

Yeah not sure if thats a proper format for a zec key

Well maybe not…
Peaking at some of my antique backup keys for transparent addresses a few of them do start with K and seem to be about that long

delete that post maybe

Yeah. Funds are in a transparent address and according to my export tool in Coinomi that would the the key.

OK also, the private key I provided is not 100% exact for security reasons but it is same length and starts with a k indeed

Dont know if there is some sort of converter or something for ywallet I tried using the Coinomi seed and it accepted it but none of the funds show up so guess its not the same thing

1 Like

Not sure if you have tried ywallet yet but this is another option:

1 Like

Yeah trying to use Ywallet. But it does not accept my Coinomi seed (OK it does but apparently its a different universe because my coins arent there). Tried to export a ZEC private key (the stuff I posted above), and says invalid. I think it expects something longer or something.

:point_up_2: Yeah i was just about to mention that there are certain quirks with zecwallet light and importing transparent addresses

ZecHub has been building up some zcashd tutorials, they also may be of use:

1 Like

I dont have Linux.

Not entirely sure I am going to setup Ubuntu plus an entire full node just to recover some coins.

I have tried sending amounts of 0.00001 from Zecwallet Lite and it still complains about exceeded limit

Zecwallet Lite has no option to change its fee (not that I know of)

OK guess I will just give up. I just wanted to recover these old coins but guess I wont be able to do so in any easy way… I got other things to do. Thanks for trying to help.

Result: Was not able to recover the coins. Thanks for trying to help anyways.

Hopefully won’t come to that (but yes if needed) the import worked according to the given error so it could be done maybe by just combining fewer notes at a time in the transaction. That way it hopefully won’t exceed the unpaid transaction limit

The reason that the import worked with zecwallet light from coinomi is likely that they were created and derived by the same method whereas Ywallet uses a different method as well as other modern wallets. There is a special method to follow to restore zecwallet type keys in Ywallet but otherwise Zecwallet light may actually still work.
Especially because you got that error. That has nothing to do with the transaction construction, it has to do with the network consensus and the fact that the transaction fee is a little bit too low.

This might be useful as well:

Just need to figure out derivation path for coinomi

A user on discord had a similar issue with safepal wallet and used:



Coinomi is a transparent wallet. To get them into ywallet, you need to use the Sweep Funds method.
But you may hit the same problem with the fees.


The next release of zcashd (v5.7.0) will not require to run zcash-fetch-params or zcutil/fetch-params.sh. In the meantime, if you can’t run the script you can instead download the files below and put them in the %USERPROFILE%\AppData\Roaming\ZcashParams directory (often this is C:\Users\<Username>\AppData\Roaming\ZcashParams, but it can vary). Create the directory first if it does not exist.

Alternatively, you could wait for a version of ZecWallet Fullnode that is based on zcashd v5.5.1 or later, i.e. probably the next release.