Issues with 6pin Riser Cables

Hey guys!

I’m currently facing a strange issue and I wanted to see if any of you has a solution for me. I just bought a couple of 6pin male to 6pin male PCIE cables to power my risers. I was trying to hook them up directly to the PSU (6pin peripheral connectors) & the risers. Depending on which PSU I hook them up to I get two different errors:

  • PSU1: System won’t power up at all
  • PSU2: System does power up and windows boots but the GPUs are not detected

That means the problem seems to be either located in the PSU (as mentioned I tried both of them but neither worked) or the cables (tried 4 different ones with the same result). Do you guys have any ideas or did anyone experience the same issue? Just as a heads up, everything works fine when I use the 8pin PCIE slots in the PSU and hook the risers up with 8pin to two 6pin PCIE. I would go with that but I don’t have enough 8pin PCIE slots in the PSUs to power the GPUs & the risers, so its not an option.

My hardware:

PSUs: 2 x Refurbished: Thermaltake Toughpower 1200W 80+ Gold Semi Modular ATX Power Supply PSU - Newegg.com

6pin cables: Refurbished: Thermaltake Toughpower 1200W 80+ Gold Semi Modular ATX Power Supply PSU - Newegg.com

Risers: PCI-E Riser Express Cable,6 Pack Latest PCI-E Riser Express Cable 16X to 1X (6pin / MOLEX/SATA) with Led Graphics Extension Ethereum ETH Mining Powered Riser Adapter Card+60cm USB 3.0 Cable - Newegg.com

My initial thought is insufficient ground. Have you tried running fewer gpus?

Some cables does not work with certain psu, look at psu end of the cable. Pin location differ. I have Evga psu, it only works with the cables that came with it.