Mac port updated to v1.0.2

My port of Zcash to Mac has been updated to v1.0.2:

As always, donation information to support my porting efforts is in my profile and on my website at https://zcash.mercerweiss.com

1 Like

I can get this up and running on a mac. Awesome! Thank you.

Zcash says it's mining but I'm seeing 0 Sol & 0 Equihash. Can this build also mine? Mining with the default solver. I've also tried Tromp solver.

I'd always use the tromp solver....and the sol/sec it displays is the average since it launched, not the average since it started mining (why is a complex matter discussed in the issue tracker somewhere :slight_smile: ), and it can take an hour or more to sync the blockchain before it starts mining. In terminal do a:
tail -f ~/Library/Application\ Support/Zcash/debug.log to see what block height its at, and compare that against the current one on https://zcha.in

1 Like

Working like a champ! And I learned something new. Much appreciated. Switched over to Tromp.

In newer versions the Block Height is on the zcash status screen.

In your build instructions you don't list the fetch-params.sh before running the build command? In the sprout install guide they fetch params before build. Does it matter if I fetch params after build?

I'm running version 1000150.

When I run
git clone https://github.com/radix42/zcash.git
I get a response that says path 'zcash' already exists and is not an empty directory? What are the commands to upgrade?

I tried
get checkout v1.0.2
but when I run
./zcutil/build-mac.sh
The response is no such file or directory

I have build-debian-package.sh
build.sh

in the zcutil directory, but no build-mac.sh

Building now, here's what I did:
from the zcash directory

git fetch -v

found the name of the build was
v1.0.2-mac-gcc
then ran

git checkout v1.0.2-mac-gcc
./zcutil/build-mac.sh

yes, you can run fetch-params.sh either before or after the build, so long
as its before you launch zcashd the first time. I'll toss upgrade
instructions into the README, thanks for the reminder!