Many blocks mined but zero balance

Hi,

I have a question about the mining process with zcash. I hope this is the right place to ask.

I have been mining for a few hours now. I got many blocks, but yet the total balance is still a perfect 0.00000000

Here are the getinfo and getmininginfo results:
{
"version" : 1000050,
"protocolversion" : 170002,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 2046,
"timeoffset" : 0,
"connections" : 8,
"proxy" : "",
"difficulty" : 47458.57049999,
"testnet" : false,
"keypoololdest" : 1477859905,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : ""
}

{
"blocks" : 2045,
"currentblocksize" : 10975,
"currentblocktx" : 4,
"difficulty" : 47458.57049999,
"errors" : "",
"genproclimit" : 4,
"networkhashps" : 2481116,
"pooledtx" : 4,
"testnet" : false,
"chain" : "main",
"generate" : true
}

The testnet key is false, and the generate key is true, si I guess this is correct.

What do you think causes this zero balance?

Thanks.

Lol 2045 is current blockchain height, not your mined blocks. You mined nothing, with current difficulty you will keep mining nothing!

Ok great. Thanks, that's a clear answer!

Type
zcash-cli listsinceblock

It will show your mined blocks if you successfully mined a block.

Ok thanks. I have no transactions, and a key "lastblock" with a hash.
It is supposed to display any other information?

I have the same problem. Did you figure it out?

I have the similar problem. Someone must suggest something.

Are you guys all trying to solo mine?

If so and you don't have an insanely high hashrate, you probably won't ever find a valid block.

I found a block with 3200s/s it can be done but I am using a pool as @vanilla1226 is correct solo mining is for the big boys or if you feel lucky it's possible but could take a long time, my block came after 3 weeks