Mining with Asus and MSI

So, I own two MSI 1070 and one Asus 1070. So I first had both MSI working perfectly fine for several weeks. I purchased and installed the Asus today. Well now my MSI will not work and the Asus works fine.

When I run the MSI I get this (CUDA: Device: 0 Thread exited with code: 4) then shows 0 sols. I've tried running two bat files using the Asus and MSI separately but yet the MSI still fail. I desperately needs guidance on how to fix this. I am using Flypool. Please assist me I cannot locate anything on the web about that.

Have you tried installing different video drivers and updating windows to the latest version? Are you using two cards on the motherboard long pci-e slots and the trird one with riser? It is unclear if one or both your MSI cards are failing. How is the failing card connected to the pc. If you swap the places, does the Asus work in the MSI slot/connetion/position. I would also update the motherboard BIOS to the latest version and go check if there is some pci express slot options disabled or something like that. And let the fun troubleshooting period begin. I also got a Error code 4 a week ago randomly (the rig was stable for a week before that). Not sure what caused it. I was using a wireless adapter to connect to the internet and the device was malfunctioning, but im not sure that it caused the error 4. Connected through lan cable and lowered the overclocks 20mhz and has been stable for the following week.