MSI Z270-A Pro 6 gpu Problem

above 4G means that all devices should be mapped to 64bit addresses, so win install MUST be UEFI otherwise your drive is not 64bit

Hi again, so I have finished the 6 GPU build.
Skylake G3900, MSI Z270A-PRO, 6x MSI GTX 1070 gaming X 8Gb.
Got working 2 card setup and added always one more.
Important info: If you want to boot the rig with less than 4 cards, you must disable the 4G encoding in bios.
I have also left the GEN to auto in bios.

So for the first added card I disabled the 4G..booted..waited for fw install..shut down added the 4th card, boot to bios enabled the 4G..booted to win waited for fw..and so on..
(if you are booting less than 4 card it will hang on bios boot screen but with mouse enabled and windows rolling booting circle)

2 Likes

Hi folks, i am having some problems to get my W10 64bits recognize more than one gpu at once. Hopefully you can help me figure what i am missing / doing wrong.
MB: msi z270-a pro
GPUs: sapphire rx560 pulse oc 4gb *4
CPU: G3900
PSU: Corsair VS550 (got another corsair rm1000x but isn’t needed yet, only start to config the rig with 2 cards and trying timings)

So, my first problem is, if i enable Above 4G Decoding on Bios after the Bios post screen i got a black screen, no matter if i got 1 or 2 GPUs connected to the board and no matter what PCI-Gen i specify nor PCI latency timer.

I tried to install w10 again with Above 4G Decoding enabled (as read above) but can’t go through that black screen (of desperation, BSOD :smiley: ) with only one GPU plugged, with two GPUs plugged, whatever didn’t work.
So i made a fresh installation with Above 4G Decoding disabled. I installed the mobo drivers, rebooted, enabled Above 4G Decoding, same thing, rebooted, disabled it, and i can reach windows,
Before i install the GPU drivers (version 17.5.1 x64 w10) i see two GPU devices on devices manager, when it finishes (before rebooting) i keep seeing 2 rx 560 (the second with that caution yellow triangle), i can select the 2nd GPU now on GPU-Z and MSI Afterburner but i can’t change the options on MSI Afterburner and GPU-Z doesn’t show me some information from the second like Pixel Filtrate, Texture Filtrate, Bandwidth or Shader (both fields).
I tried now to enable Above 4G Decoding on BIOS and now i can boot to windows :confused: but i still have this problems with MSI Afterburner and GPU-Z.

I forgot to say that i am not using risers right now because didn’t arrive yet, both GPUs are plugged directly on the 2* pcie 16x/8x slots.

Halp please, thanks in advantage.

nvm, my problem with the black screen was in the installation media, i didn’t select gpt partition for the pendrive :confused: and i needed that trick with two drivers versions, now it’s working :smiley:

Hi guys
New to this forum ...
I know this is for Z270-A but I was curious if any one can help me here.
I have gone crazy to setup 6 GPU, 5 works ok with no problem
When I enable the 6th, after 10-15 minutes, cpu usage goes high and reach 90%. no program with high cpu in task manager but "system"
If I leave it like that after a while system freeze.
All 6 GPU are detected and working fine, tried to run with 5 and cycle the 6th one to check if problem is from risers or power cables ( Disabled pcie1 , run with 5, disabled pcie2 run with 5 .... )
All ok with 5 GPU no matter which one, as soon as I enable 6th the cpu goes high.
system is :
Windows 10, 1703 , all drivers updated to latest with "Driver Booster"
Mobo: MSI Z170A XPower Gaming Titanium Edition
PSU: Thermaltake Toughpower XT Gold 1275W
GPU: 6x 1070 Asus Dual 8OG
Ram: ADATA XPG Z1 DDR4 8GB 2800MHz CL17 Dual Channel
CPU: Pentium G4400 3.3GHz LGA 1151 Skylake CPU
HDD: SAMSUNG 750 EVO 120GB SATAIII Solid State Drive

PEG0, PEG1, PEG2 gen 1 (tried with auto too)
4G enabled
IGD disabled (tried with enable too)

Hi, I noticed I have the same problem as you. Just been wondering if you’ve been able to figure out what the problem was, as I’m still struggling with it. Any help is much appreciated, thanks in advance.

I have a problem with z270 gaming main board with 6 gpu RX570 if don’t enable 4G mining option in bios (1.3 version) I see only 3 vga if enable 4g option window’s don’t start. I tried install Ubuntu and windows 10 with 4G enable black screen on the boot, whit 4g disable install ubunt and w10 but 3 vga don’t working
I tried 2 gen option , 1 gen option, 32 and 96 latence in all optin blank screen on start whit 4g enable, can yio help me, thank’s

I install driver amd driver 16.11.5 into 17.5.2 and install one vga card for time
now g4 working (enable), i setup 96 latence and gen2 or gen1, but see only 4 rx570 and not six
main board is msi z270 gaming m3

I have been going back and forth with this MSI 270 z rig for months now… only using 4 XFX RX 580 8 gn radeon cards… According to MSI official blog/ FAQS this motherboard at most can run 4 gpus… and thisis the he result i get… the 4 th always errors oit with Error Code 43 ( Windows 10) aka shows up on display adapters but has yellow exclamation point next to name indicating problems with drivers etc. Basically long story short this motherboard is not optimal for mining at all… 7 pcie slots yes but ive yet to meet / read/ dream about anyone actually running 7 gpus on MSI 270 z… if you can return it do so ASAP… got the new BTC ASROCK motherboard… runs 13 gpus lol so far i ran 6 with no problems