Zec Fullnode 1.8.7 for windows

Hi!

I’m running Zec Fullnode v. 1.8.7 on Win10 but I get this error:

2023-06-14T08:19:35.740556Z INFO ProcessNewBlock: main: *** This version has been deprecated as of block height 2121024. You should upgrade to the latest version of Zcash.
2023-06-14T08:19:35.740563Z INFO ProcessNewBlock: main: Error: This version has been deprecated as of block height 2121024. You should upgrade to the latest version of Zcash.

Ther is a new version of Zec Fullnode to donwload?

Thanks, Ale

2 Likes

not sure how old that is. we have zcashd 5.6.1 fullnode Zcash Full Node and CLI — Zcash Documentation 5.6.1 documentation
or the new other option is zebra 1.0.1 node

1 Like

Hi zerodartz!

My zcash versions is 5.4.2 and it is released with https://github.com/ZcashFoundation/zecwallet/releases/download/v1.8.7/Zecwallet.Fullnode-1.8.7-win.zip windows package.

So I suppose I need to download 1.8.8-win.zip version ?

Thanks, Ale

1 Like

Ok dont have experience with that wallet exactly. maybe @Autotunafish can help.

1 Like

zcashd 5.4.2 reached its end of service halt height on June 13, 2023. The current version is 5.6.1. You will need to upgrade zcashd to a current version.

1 Like

Also it looks like ZEC Fullnode hasn’t been updated since April, which would explain the version difference on zcashd. There have been some significant changes since that time specifically related to node sync performance, proportional fees, etc.

1 Like

Correct zec wallet full node has not been updated and will not function. Windows, by itself, is not a supported full node platform as you would need WSL or some VM. The fastest way to regain spend authority is to import your backed up private key(s) into a light wallet.

1 Like

The other option is a Docker container
https://hub.docker.com/r/electriccoinco/zcashd

1 Like

Hello, I am in the same situation with my (formerly working) Zec Fullnode.

I have taken your advice and successfully spent/moved my zcash in Sapling address.

However, this is not working for zcash in my pre-5.0 legacy addresses.

I have the private keys accessible but none of the light wallets I have tried (Zecwallet Lite, ywallet, Nighthawk, Zingo!) will let me import a legacy key.

Any further advice for this situation? Thanks!

1 Like

Be sure that the formating is correct with no extra spaces. Sapling keys begin with the prefix ‘secret-extended-main’ and thats required in the whole key

Those Sapling keys that start with “secret-extended-main” are the ones that I have successfully imported into a light wallet.

Perhaps I don’t know the name of what these original (not HD) private keys are called (from the original zcashd) but they start with a L… or K… These are the keys that I cannot import to any light wallet I’ve tried.

Any ideas?

Thanks for your help!

1 Like

Those would be transparent address spending keys. Does the wallet simply refuse to import them or does it import them and then show zero balance?

Zecwallet Lite, ywallet, Nighthawk, and Zingo have all refused to import them.

Over 2+ full days wasted now working on this and scouring the internet for a solution unsuccessfully.

Have you tried one of the exchange-based wallets that fully support t-addrs, like Coinbase? Had a similar problem months back and that was how I got things restored.

1 Like

If the wallets complain that the keys are invalid then it seems like a corruption with the backup and the keys are missing some characters or were changed somehow.
If the addresses were regenerated with zecwallet full node, and if you can restore the original seed, then you can restore the transparent ‘sub-accounts’ in Ywallet.

Also that up there :point_up_2:

FYI, ywallet has a searchable help and you can also use Google.

ywallet legacy keys in google.

Also, another user had the same problem a few days ago.

2 Likes

Thanks for your help guys. Sweeping with ywallet seems to be working for these transparent keys.

I had looked around in that exact help area in ywallet and read these support threads, but it seems like this was a case where I didn’t realize I needed to sweep funds from old addresses to continue using them.

This is a different process than importing the Sapling addresses, which did work as expected, and I was thinking that the “sweep” functionality (which I did see in ywallet’s Advanced menu) was for addresses/funds that were already in the wallet.

1 Like

As an alternative option, a ZecHub contributor just dropped a video explaining how to run zcashd in Windows!

1 Like