Nheqminer will not run with -cd 0 entry - SOLVED


#1

Hello fellow miners!

First off, I'm new to mining so bare with me. I'm running an AMD FX 8350 alongside of a GTX 970 and am having trouble getting the GPU to mine. Whenever I add -cd 0 to my batch file and run, the window just opens and closes immediately. This is my current batch file parameters which are only utilizing the CPU:

nheqminer -l usa -u 1B3uQaqunpEDAN8HYG4uDKfP2ymyzStjyT

After researching for hours I'm unable to find anything!

Thoughts?


#2

What pool are you trying to mine to? Your mining address doesn't start with a "t" so it doesn't look like a valid t_address.

Also:
Are you sure it is GPU 0? Does your mobo have onboard graphics? If so, Have you tried -cd 1?


#3

try: nheqminer -l usa -u 1B3uQaqunpEDAN8HYG4uDKfP2ymyzStjyT -t 0 -cd 0


#4

WOW, super quick replies thank you!

@aclymer I had just followed the guide over @ https://github.com/nicehash/nheqminer/releases which states the following:

"Mine on NiceHash.com service as a hashing power seller, using CPU and NVIDIA GPU, using USA location:
nheqminer.exe -l usa -u BTC-ADDRESS -t 6 -cd 0

In this example we have a quad-core CPU with hyper-threading (8 threads available) and only one NVIDIA GPU in the computer. We are mining with 6 threads on the CPU and on the whole NVIDIA GPU."

I'm not sure what T_address you're referring to. It appears to be running properly when I utilize the CPU only.. ~17 Sols/s. -cd 1 is a no go, no onboard graphics.

@t2yax No dice...thank you.


#5

So nicehash converts your ZEC to BTC, that's... nice... ha. In your batch file add pause on the last line and you will be able to see the error info.

e.g.

Then you can post the error on here and we can help you better.


#6

It is nice, isn't it! Great for newbies like myself :slight_smile:

Thanks for the 'pause' tip, I think I'm on to it now...error is as follows:

CUDA error 'CUDA driver version is insufficient for CUDA runtime version' in func 'cuda_tromp::getinfo' line 45

It appears that it's related to my driver version. I have installed 347.52 which is supposed to work in Windows 10 and had worked in another nheqminer instance, but now it's not. I'll have to play with the driver at this point.


#7

Did you do a clean install? the GTX 970 is new enough that it should work. The latest drivers is 375.70 WHQL


#8

Trying the latest drivers now...


#9

@aclymer Thank you SO much for your help, mystery solved! Latest drivers are working. I'm running ~44 Sols/s now.