Nvidia mining EWBF Ubuntu issue with greater than 4 cards

I’m running Ubuntu 16.04 and I have good success with 4 cards, with nothing additional on my kernel command line.

The motherboard is an Asus Z270-A motherboard with the PCI Express setting currently set to Gen2 instead of Gen3.

However when I added two additional cards I encountered an I/O region error in dmesg from the nvidia module (version 384.98) and i basically had to start adding in an acpi=off command line option for the kernel, to get six cards to start working.

Currently the relevant line in my /etc/default/grub looks like this:

GRUB_CMDLINE_LINUX=“noapic pci=noacpi,biosirq acpi=off vga=788”

And my dmesg for nvidia shows an RmInitAdapter failed! (0x24:0xf:1077) message.

The EWBF miner (version 0.3.4b) shows reduced Sol/s for each card when running all of them, or 0 Sol/s particularly after a GPU0 Rejected share message came up.

I will be looking for a bios update over the holiday to see if that fixes anything. It would be nice if the system didn’t need the acpi=off line because the system runs fine with enough address space for 4 cards, but it looks like if I go for any additional I will have to tweak something.

you will need to do the following
update your bios
turn on Above 4G Decoding set to Enabled in the bios
set PCI-E to gen2 in the bios
disable sound in the bios
disable ieee1394 in the bios
Driver Manager install
select the nvidia-375 or newer if not already complete
install dev tools
sudo apt-get install cmake build-essential libboost-all-dev screen
install Cuda toolkit if not installed
you will also need to update your xconfig to reflect the additional cards run the next two commands to do this
sudo nvidia-xconfig --enable-all-gpus
sudo nvidia-xconfig --cool-bits=12
You will need to run the last two commands every time you add a new card

Yes, I went back to the cuda 8.0 release of 375.26 and its running much better. Also completed a bios update from version 0505 to 1009 on the motherboard. I also adjusted CSM and the 4G decoding, as you pointed out. I’m running 5 cards now and the hash rate is running well, even without any kernel command line options (thanks to the bios update, acpi apparently is working better now)

Unfortunately the 6th card was running at a low hashrate yesterday before these updates (about 28% to 50% of the speed of other cards) and when I went to diagnose it today and was checking over the power connections I was just inserting the riser adapter into the motherboard and I accidentally plugged it in reverse. The power was off at the time but I did power cycle the machine once, to test the system. Apparently that was enough to kill the graphics card because it isn’t showing up on the lspci | grep vga listing anymore. It illuminates but it isn’t showing in the lspci listing.Maybe the card had problems from the beginning but I will let it rest overnight out of the system and then try it again in another machine. (I already tried it with different risers and slots and can’t get it to come back online at the moment)

So it looks like the software configuration and bios is good for now to run additional cards but I stupidly may have lost a card in the process while setting everything up.