Nvlddmkm.sys Blue Screen of Death error

#1

Mining ZEC on Suprnova with EWBF miner

7x 1080ti Zotac GPU’s

ASUS A270 mobo, all settings relevant set to Gen 2 and 4G encoding enabled

8GB ram, Core i3, 4 cards on 1 1600W PSU, 3 cards on a 1000w PSW

About 10 seconds after I start the EWBF miner, I get a BSOD with the nvlddmkm.sys error and the system restarts. I’ve installed and am running the latest Windows 10 update, and the latest Nvidia drivers.

What gives?

#2

Reinstall drivers? Reinstall the OS?

#3

Im having the exact same problem.

Running Asus Strix 1080ti cards.
2x 1200w
8gb ram
i3

Cards are found and installed, but when starting to mine it crashes within 5 minutes BSOD with the nvlddmkm.sys error.
I have tried to run only 5 cards, same problem.

I have reinstalled Windows 10, 3 times
I have reinstalled drivers multiple times, tried to let Windows install the drivers on its own, manully updating to latest nvidia drivers and so on. I cant get it to run.

I have tried to switch out risers.
Nothing seems to work.

#4

Hey, I am having the same problem. I know this is a long shot, but how did you fix this issue? Thanks!

#5

Try uninstalling the NVIDIA drivers and then doing a fresh install with the latest drivers. If that doesn’t work, repeat the process and try with an NVIDIA driver one version earlier.

#6

5x 1050 ti sc 4gb
4gb DDR4 RAM
1000w psu
quad core I3 7th gen processor
asus prime z270-p mobo
EWBF Zcash cuda miner 0.3.4
current driver: 388.74 - because it was the last known working driver on this rig.

Hello, I am experiencing the same problem. Either a few minutes into launching the bat.file the whole system crashes to a nvlddmkm.sys tdr bsod or if I unplug everything and plug the cards back in one by one I can get it to run for a few hours. It Just started a few days ago when the new Nvidia drivers came out. I have tried almost everything to get it fixed. I’ve used DDU to uninstall old drivers. I’ve tried several different driver versions that did work in the past. I’ve tried increasing the TdrDelay and setting the virtual memory to 10000 min 20000 max. I’ve switched cards around. I’ve tried different risers. All to no avail.

They really weird thing is that I can mine ETH no problem. All 5 cards work at 12 mh/s and it runs indefinitely as far as I know. So my thought process is that it may be the EWBF miner or the block chain has a memory leak somewhere. Is that possible? Has anyone found a solution to this problem?

#7

After more digging through the internet and trying different things I think I found the answer we all seek. I downloaded and installed the latest CUDA tool kit from the Nvidia site. (link below). I was able to start the EWBF miner with no crash and it has been running successfully ever since. The reason for this is because there are drivers in the toolkit that are not in the normal driver updates. Having these other drivers it corrects whatever is causing the nvlddmkm.sys error. I’ll report later if the rig goes down again or if it continues to run.

https://developer.nvidia.com/cuda-downloads

1 Like
#8

you need to go here https://developer.nvidia.com/cuda-toolkit to be able to download it, you’re link is one step to far.

#9

Machine has been running for 19 hours without interruption and I’m getting around 170 Sol/s per card. This is the solution I was looking for and I hope it helps anyone else with this problem.

1 Like
#10

Worked for me, now my rig is stable ,thank you so much

#11

Woah … I’m getting the same “bsod” error every single time I initiated my system. I was starting to think that the problem is related to some kind of hardware malfunction… but my cards are watercooled and running with low temp… Tried and tested every hardware piece with every method written on internet … problem kept reappearing everytime …
I was almost gonna suspect from myself, becouse thats was the only thing that havent changed on these tests :slight_smile:
Now I m downloading the toolkit .
I hope it works …

#12

You need to install the latest version of Nvidia drivers and install… you had an update the corrupted the file.

#13

hmm, I have already tried every method written on the internet. Including the ddu and latest nvidia drivers. that haven’t solved the problem . other than installing cuda toolkit, I also detached and re-established every psu and gpu cable connection.
Now it works …

#14

no … it doesnt work …

#15

Its a big issue to resolve this problem [Nvlddmkm.sys Blue Screen of Death error]. You can easily fix this error easily.

1 Like
#16

First format your computer then install all OS and drivers or other software.