Problem with Mining rig 4 cards

Hi dear community

First of all sorry for my english, i'll try my best:)

I really hope someone can help me because I really start being desperate.

I have bought several used gtx 1070 gpu's and all necessary hardware for building a mining rig or at least i hope so:

CPU : Intel Dual Core Pentium G4400, Sky-S
SSD: Kingston HyperX Fury 120GB, 2.5", MLC 59.54 8.00 SATA3
RAM: HyperX FURY DDR4 4GB 2133MHz, Black Series
PSU: Cooler Master, V Serie 1200W
Mobo: MSI Z170A Gaming Pro Carbon (LGA 1151, Intel Z170, ATX)
Riser Cables : PCI-E 1x to 16x Powered USB 3.0 Extender Risers (http://www.ebay.com/itm/310897618647)
OS: Windows 10 Education N 64 Bit
GPU: 4x GTX 1070

After several hours off trying and testing i was able to make the system detect 4 gpus (i have ordered more for a total of 6 gpus on my rig, they have not arrived yet). Amongst other things i have therefor followed these steps 1-9: http://1stminingrig.com/msi-z170a-gaming-pro-carbon-motherboard-review-mining-performance/ (I Have installed newer BIOS version 1.8).

I tried the miner and then i had the first problems. 2 gpu’s have good sol/s around 450, but one has like 120 and the 4th like 70 (and not spinning). So i tried to figure out what it could be and therfore i exchanged the gpu’s with other 1070 models -> same problem. Furthermore the PC freezez after a couple of minutes.

So i tried with the Nicehash miner and it seemed to work just well. All GPU on a good and constant level. The problem? Its only working for like 1-3 hours. Then the rig is not mining anymore, i have no singal on the monitor, but the GPU’s fans are spinning. I cannot do much except turning off the PSU. After a couple of seconds i press the power switch and the System boots normally and i can login to windows.

Please can someone help ? Maybe i dont have enough RAM ? What could it be ? i have spent hours and hours and hours trying to solve the problem without any success.