Ready to jump to linux

ok i am sick of the constant issues with windoze so i am going to give linux
a go. I used to run suselinux about 15 years ago, so have opted to go for that again. just after any tips or tricks anyone found useful during the setup phase for the miner etc, or any traps to avoid during the setup


Could always give Hive OS or simple mining OS a try both are Linux based and run off a USB stick or an SSD

I am using linux mint 18 cinnamon , looks similar to windows and all drivers installs automatically .
just install it and download the miner and give it a go .

you might want to manually lower the tdp though , using " sudo nvidia-smi -i 1 -pl 225"
where -i 1 is your gpu number and -pl 225 is the watt limit . ( this is a 1080ti gpu number 1 on my rig )

those numbers you change them according to your rig and GPUs .
remember you have to be root to do that , to be a root you need to type " sudo -i " then enter your password.

for my part I installed it while connecting only one GPU to automatically install nvidia driver . and after adding the rest it recognized them all .

rig runs solid no issues whatsoever.
you should be up and runing in less than 30 minutes.

The new version is coming, if you go to the zcash4win website, its a redirection link to WinZec (a most frustrating issue indeed, ive tried everything I can think of too)

thanks for the tips will definately have a look at the mint 18 and yes i tried SMOS but it keeps corrupting the USB stick about every 24 hours i have to reflash it to get the rig to run, so i figured a “proper” install would be better

You can always try ethos. I use it to mine zec and ethereum

Ok i ended up going with mint, the suse installer kept crashing but mint installed no problems, one question, did you have any other issues getting the miner to run, if i try the it tells the miner doesnt exist.
I can run the miner manually but it crashes sometimes looking for an Nvidia file. I did the driver update at install and it looks ok, just wondering if i need soemthing else, like on my windows 7 rig i have to install the dotnet framework to get the miner to run properly.


in administration menu , choose driver manager . and check if you are using the nvidia . if not choose nvidia driver then apply and restart.

I am using nvidia-384

that’s all what I did after clean install .