REQUIRED config change for zcash4win 1.0.12

You MUST add the following line to the file %AppData%\Zcash\zcash.conf


for the current release of zcash4win to function. You may need to show hidden files as described here:

There are no security fixes or new features in the more recent versions of zcash for linux, although performance is improved. I’m working on getting those versions’ changes working on Windows, and will have a new release hopefully soon


any risk or danger to add this parameter in the config file???

p.s. after added this parameter, it can start now…
actually what is the cause of the error???

Hi, you knew why this version is no longer valid?
It will happen often?

@lubu Adding this disable depreciation to your configuration won’t hurt your Node.

It is set to activate about two versions (certain # of blocks) behind the current version. So when 1.0.15 is released the clock will begin ticking for 1.0.13.

As we stated previously, once a version is deprecated via the auto-senescence feature, nodes running that version will automatically exit when they detect they’ve reached their deprecation phase. This feature will always have the ability to opt-out but it’s important to note that for deprecated releases, the only help the Zcash Company user support team promises is in upgrading to the latest release.

its not “no longer valid”, its “zcashco wants to discourage older ones from running in case of security fixes”, and stuff like that

but there won’t be a newer version for Windows until i get it running, as they don’t support windows in the first place

and as I note elsewhere, ZcashCo doesn’t support Windows officially in the first place, and there aren’t security fixes since 1.0.12, just performance improvements, experimental features, and some new api calls for devs. I myself can’t wait to get the performance improvements working on Windows, as I “eat my own dogfood”, as we say in software, and use zcash4win for all my stuff, too!

From yesterday onwards can not be used normally, this is the software interface, what is the problem?


1 Like

thanks for the info on fix works again
Thanks you for posting the fix

[quote=“radix42, post:1, topic:26632”]
[/quote] Hi i have problem to open my zecash wallet i been receiving payment thru flypool but i can not open may wallet its taking long time what i do help me please

Thanks for your effort! 90% of people use Windows so this is a major up for this coin.

I’m actually a newby to zcash, who found this wallet/coin as one of those which recovered somewhat better after the recent BTC bloodletting. I liked the terms a priori, but almost tossed in the towel when I saw it was only available in Linux. Wish I had Linux. It required an extra Google to discover that a working Windows version is already available, your zcash4win (nice name)

FYI: It was necessary to ignore a warnings on my W8.1 box from the native antivirus, but deemed it likely a false positive. Also couldn’t find a a folder/file named …/zcashzcash.conf until I took another leap of faith and ran the wallet exe. Then all seemed to fall in place, and I had no problem adding the extra line to zcash.conf which is under my username in the Apps/Roaming folder.

Haven’t explored your wallet yet, although it seems to run OK., so think I’ll hang around and watch for developments.

My only prior interest is in a coin whose name you can find at one of my webpages (not intended as an ad): Still a newbie there too, but am just today learning how to setup up a Plot for mining.

how exactly are we supposed to apply this fix? Where in the config file am I supposed to insert the line?

It goes in %appdata% zcash CONF file, edit in notepad put as last line

The trick appears to be un install and delete roaming data, then reinstall.
Then when it opens, close it, edit, save, reopen and import private keys.
Simply editing wont work, this might, i’ll relay once the chain has downloaded.

just the adding of the line radix42 told us is enough.

Yeah the patch worked on win8 but win7 wasnt having it, sorry should have specified, and actually now im wondering if its the machine
The daemon wouldn’t launch, after reinstall it did launch but stuck downloading chain at 4.98%, strange

I am installing ZCash4Win on a new computer today. I have located the *\ZCash\ Folder, but there are no files in it. The wallet has not run other than to get to the “It’s taking too long” part. What can I do?

that sounds like a new issue. I mean, if you don’t get any files then it prolly means that all new installations have problems to get somehow those files, without an additional change in the software. If I have enough time this evening I will try to install zcash4win on another client.

1 Like

The wallet has to open up and start running in order to create the roaming folders
Uninstalling won’t delete these folders just like installing it won’t initially create them
I’ve got another machine with Windows 7
I’ll play with more tonight see if I get the same result

I’m thinking that it might be possible to copy everything from an existing installation onto this new one. This is really something for the developer to sort out, however, and since we’re playing with sums of money, it’s important.

I run windows 10 so for me i did the followingcut and paste %AppData%\Zcash\zcash.conf into the search bar in task bar then double clicked it then cut and pasted disabledeprecation=1.0.12then saverestart walletHope it works for you

February 8 |

how exactly are we supposed to apply this fix? Where in the config file am I supposed to insert the line? Visit Topic or reply to this email to respond.
In Reply To

February 4 |

thanks for the info on fix works again Thanks you for posting the fix Visit Topic or reply to this email to respond. To unsubscribe from these emails, click here.