Set up your own private stratum pool


#141

I think this is a bad idea. www.zogpool.org just found a block with 6k sol/s and www.luckpool.org is working its way up to maybe a block every two days. I'm happy with a smaller pool. (the zog payouts seem better than flypool at this point)

Also having more pools is good for the mining ecosystem and helps prevent centralization.


#142

What type of pools are these? P2Pool? What is a p2pool?


#143

Its a stratum pool ... as far as i know, there are no P2Pools for zcash ... yet


#144

It was a problem with my virtual machine, I edited some settings and everything went well. Now I'm little bit confused how can I make it to sync blocks ?


#145

you run zcashd on its own until it reaches the current block ... something like this:


#146

It confused me more :slight_smile:
The last command was /usr/bin/screen -dmS "zecnode" ./ZEC/zcash/src/zcashd
should install it separately ?


#147

@mettalmag ... hope this helps :slight_smile:


#148

That was the part that confused me, let me re read it again and see if I missed something.


#149

Ok here's what happened, after running script I got the error
nginx: [error] ngx_http_cxxrest_pass_handler: got destination: api_backend
and one more, should I see the block syncing progress ?


#150

running the pool mainly should have 4 processes running:

  1. zcashd
  2. poolrestapi
  3. the pool frontend
  4. nginx

the bash script runs all 4 from one script, which is usually what you will need to do... but since this is the first run, and you have to sync the zcashd ... so you only run the zcashd part ... wait on it till it syncs ... stop it ... and then run the scrypt


#151

this is not an error ... its a debug msg from nginx


#152

hi
server is up , wallet updated , web is up , but still can not connect my miner to server..
do i need to install stratum server?


#153

What miner are you using?

Silentarmy, nheqminer, and claymore should work!!

Optiminer does not work :frowning:

And what's your pool's url?


#154

@megacrypto I am using nheqminer

i use this format : nheqminer -l aa.bbb.cc.ddd:3357 -u xxxxxxxxxxxxxxxxxxxxxxxx -p x
I dont have domain name , i use ip address.


#155

I run nheqminer as follows:

Nheqminer -cd 0 -l megacrypto.servebeer.com:3357 -u myTaddr


#156

Ok... sorry didn't see the second part!!

Yes you can connect with IP normally

Are you sure the frontend is running... when you "screen -r zecpool" what do you get?


#157

@megacrypto

root@localhost:/# screen -r zecpool
There is no screen to be resumed matching zecpool.
root@localhost:/#

strange I was sure it worked before.


#158

Just close any other screen's running...reboot... and run the sh script and see if all picks up


#159

@megacrypto I did , and still the same.

PS: I am using VPS from 1&1


#160

@megacrypto

i used to run .zcashd and I get the screen

now i just noticed that the scree that i got is = to what " screen -r zecpool " output.

so this is my screen , and still not working my miner.

this what i get

[10:46:00][0x00002490] stratum | Reconnecting in 3 seconds...
[10:46:03][0x00002490] stratum | read_until: A request to send or receive data w
as disallowed because the socket is not connected and (when sending on a datagra
m socket using a sendto call) no address was supplied
[10:46:03][0x00002490] stratum | Reconnecting in 3 seconds...
[10:46:06][0x00002490] stratum | Connecting to stratum server aa.bbb.cc.ddd:3357