Unable to import old wallet

If “zcashd -rescan” is executed, does it mean that my backup file needs to be placed in a specific location? Can be recognized by “zcashd -rescan”

Do you have the wallet.dat file from Zec4win?

That is all you need, don’t copy anything else.

  1. Start a fresh ZecWallet Fullnode and let it fully sync 100%. (You can choose fast sync option)

  2. Stop ZecWallet Fullnode and replace new wallet.dat file with old one from Zec4win.

  3. Restart ZecWallet Fullnode with -rescan so it will search the chain for your funds in the wallet.dat

Glad to see such a reply.

The problem is that I now start the wallet like this

./Zecwallet.Fullnode-0.9.22.AppImage --no-sandbox

Should I change it to start like this

./Zecwallet.Fullnode-0.9.22.AppImage --no-sandbox -rescan

My Zec4win backup file is human readable, ZecWallet’s default wallet file is not readable, I renamed the backup file to wallet.dat, compatible?

I just tried again “Zecwallet_Fullnode_0.9.23_amd64.deb”

d@d:~$ zecwallet 
Tracing and Breakpoint Traps 
d@d:~$ sudo zecwallet 
[1231:1209/165927.925432:FATAL:atom_main_delegate.cc(211)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
Tracing and Breakpoint Traps

Tracing and Breakpoint Traps ##This sentence comes from my translation

Tested under debian10

Can you check debug.log and db.log for errors? There should be something in the last 20 lines.

Also, it would be very helpful to run under gdb.

$ gdb zecwallet

Type r and press enter.

After it crashes, type bt and press enter. Then post the backtrace here.

If you’re on debian, you need to start with --no-sandbox. This is a debian-specific issue.

To rescan, you need to pass the argument to the zcashd binary. If you installed the .deb, you can just run zcashd --rescan from a terminal, which will start the zcash daemon. You can then start zecwallet, and it will connect to the running daemon.

Can I run “zcashd --rescan” like this “./Zecwallet.Fullnode-0.9.22.AppImage --no-sandbox -rescan”

d@d ~> gdb zecwallet
GNU gdb (Debian 8.2.1-2+b3) 8.2.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from zecwallet...(no debugging symbols found)...done.
(gdb) r
Starting program: /usr/bin/zecwallet 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ffff2e18700 (LWP 1250)]
[Detaching after fork from child process 1251]

Thread 1 "zecwallet" received signal SIGTRAP, Trace/breakpoint trap.
0x000055555a0b8ae4 in ?? ()
(gdb) bt
#0  0x000055555a0b8ae4 in ?? ()
#1  0x0000000000000fa0 in ?? ()
#2  0x00002364a330d870 in ?? ()
#3  0x00007fffffffd8e0 in ?? ()
#4  0x00002364a3323a80 in ?? ()
#5  0xffffffffffffd900 in ?? ()
#6  0x000055555bf5acc0 in ?? ()
#7  0x00007f00ffffffff in ?? ()
#8  0x00000000ffffffff in ?? ()
#9  0x0000000000000000 in ?? ()

d@d ~> uname -a
Linux d 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux

I am confused about the testing environment before the release of zecwallet. Why did the developer not encounter the problem I encountered

Aditya is the ZecWallet developer and answered above:

Oh, I am confused, I pointed out above that I can only run normally “./Zecwallet.Fullnode-0.9.22.AppImage --no-sandbox”

But what Aditya told me is the .deb method

I need to know how to run “zcashd --rescan” using .AppImage

I think the reason why zcash has not been widely used is because ordinary users cannot run wallets.

I planned to invest when zcash was public, because there are many difficulties in running the official wallet of the wallet. Until after zcash4win appeared.

zcash4win is very good. It is very easy to run and has never encountered any problems. I am very confused why it disappeared.

If the zcash wallet is as easy to run as other mainstream currency wallets. Its usage rate and price are more than that.

It’s much simpler and faster if you just use ZecWallet lite and don’t have to download the entire blockchain :slightly_smiling_face:

I need to know how to run “zcashd --rescan” using .AppImage

I mentioned earlier that I used the .AppImage package to run normally and synchronize all the blockchains. I need someone to tell me how to import zcash4win backup files

You seem to be making this much more difficult than it has to be. You don’t need to use the command line or .Appimage files to recover funds from an old Zcash4win wallet.

You have a very unusual operating environment (nobody really uses .Appimage) and a extremely old piece of software, zcash4win has been abandoned for years.

If your goal is to recover the Zcash from Zcash4win then the easiest way to do that is:

  1. Use a PC with Windows
  2. Get the wallet.dat file from your Zcash4win backup folders
  3. Download ZecWallet Fullnode for Windows and let it sync 100% (use the "fast sync option)
  4. Replace the ZecWallet wallet.dat file with the Zcash4win wallet.dat
  5. Use ZecWallet “rescan” option

That’s it, after the rescan your ZEC should show up and you can send the ZEC to any wallet on any operating system you prefer to use.

Glad to see such a response.

Oh Mega, I can’t complete the data block synchronization using windows-ZecWallet , it always synchronizes to about 50 and an error occurs, prompting to view the huge log.

How much RAM are you giving the machine that is running ZecWallet? Sync in Zcash can fail if it runs out of memory, give at least 6GB RAM to be safe.

Zcash has a mysterious error, I will try more than 6g of memory.

Waiting for my result

The data block is only about 10GB,

Why I synced about 16% but spent more than 50GB of data traffic

It took me two days to synchronize the data, and it took about 80GB of data in total. This is abnormal

The strange thing is that this time I didn’t get any errors under windows

After I replaced the file, running ZecWallet gave the same error as in the past.
How to run rescan under windows-ZecWallet

I restored the original .dat file and ran ZecWallet and there was also an error.

1 Like

Ok, so you let ZecWallet sync 100%,
Stop ZecWallet.
Replace wallet.dat
Restart ZecWallet with -rescan

If that doesn’t work and you get a corruption error:

Try restart with -reindex