Upgrading from v1.0.7 to v1.0.8 on Ubuntu

I am upgrading from v1.0.7-1
I am building from zcash source on Ubuntu 16.

I checked out the new v1.0.8 branch following the upgrade steps in 1.0 User Guide

However, I ran into a problem.
Note, that "make clean" will fail due to missing dependency "libevent".

I tried "sudo apt-get install libevent-2.0 libevent-dev"
This did not fix the dependency issue.

Long story short...these steps worked around the issue and "fetched" what was required.
First, "./zcutil/build.sh"
Second, "make clean"
Third, "./zcutil/build.sh"

now running zcash v1.0.8 awesome!

1 Like

You're right that make clean doesn't work reliably; I've filed https://github.com/zcash/zcash/issues/2226 about that. In this particular case, a single zcutil/build.sh would have worked.

2 Likes

I've also removed make clean from the upgrade instructions.

1 Like

I have 2 Ubuntu 16 machines that have been running zcash CPU mining for about 2 days having followed the installation steps in the 1.0 Sprout guide. Just trying to get the hang of this and linux before moving to a mining rig.
The third one that I setup today has a different Zcash interface and is running a faster Sol rate that the others (same configuration).
What command do I use to with Ubuntu to find the version zcash I'm using? Some what new to linux.
Also, if I need to upgrade, do I need to do a new zcash install following the Sprout guide?
Thanks in advance!

zcash-cli getnetworkinfo

{
"version": 1000850,
"subversion": "/MagicBean:1.0.8/",
"protocolversion": 170002,
...

Upgrading is simple. Follow the sprout guide.
Basically, fetch the latest from zcash repository then run ./zcutil/build.sh

Each miner you plan on setting up doesn't necessarily need its own zcash node.

Have fun experimenting, I sure am!

1 Like

Thanks! Will give this a go

Tried zcash-cli getnetworkinfo command, but get unknown command. What directory should I be in?

You should be in the zcash directory created when cloning the github repo.

Per 1.0 Sprout Guide

$ git clone https://github.com/zcash/zcash.git
$ cd zcash/
$ ....build normally...
$ ./src/zcash-cli getnetworkinfo
2 Likes