⚠️ Zcash 1.0.3: Important upgrade for Miners/Pools/Users ⚠️

Zcash 1.0.3 has just been released: https://z.cash/blog/new-release-1.0.3.html

This release contains several important bugfixes, and all users are encouraged to upgrade. One of these bugfixes protects you and the network from a cache invalidation issue that could allow an adversary with sufficient resources to cause a denial of service attack or chain fork.

5 Likes

Mac users, ICYMI, I've also updated my fork to track v1.0.3:

2 Likes

Kudos core devs, this is an important update with all the fixes it has...looking forward to v1.0.4

2 Likes

I think autoupdate option will be great to be added in the future, also with the option to enable or disable.

So in the meantime
What is the correct way to upgrade under linux
installed from github

1)update local repository
2)make uninstall?
3)rebuild?

Here's how to upgrade for the Mac build.

cd zcash
git checkout v1.0.3-mac-gcc
./zcutil/build-mac.sh

For linux: (need someone to verify)
cd zcash
git checkout v1.0.3
./zcutil/build.sh -j$(nproc)

To see the different versions available for the checkout command
run
git fetch -v

I got an error on Ubuntu 16.04. Weird since I had no problem upgrading to v1.0.2

mv -f script/.deps/libzcashconsensus_la-interpreter.Tpo script/.deps/libzcashconsensus_la-interpreter.Plo
make[2]: Leaving directory '/home/****/zcash/src'
Makefile:7457: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/****/zcash/src'
Makefile:676: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

Try this:
git clean -f -x -d .
./zcutil/build.sh -j$(nproc)

from this page

1 Like

In my main nheqminer folder, I ran git clean -f -x -d . but when I go to run the second line of code, ./zcutild/build.sh -j$(nproc) it says that there is no such file or directory. Which directory should I be in when I run the second line of code?

Scratch that - had to be in my zcash folder.

Cheers

it didn't work.... This is giving me a head ache man

@guizmo what other errors appear before what you posted when you run ./zcutil/build.sh?

Solved. I'm actually a bit embarrased.... It was a permissions issue. Just needed sudo. That's it.

Thank you @ebfull and @fibonacci for your time.

2 Likes

issue with mac compile...
any clue?
thx

In file included from ./boost/system/system_error.hpp:14:0,
from ./boost/thread/exceptions.hpp:22,
from ./boost/thread/pthread/thread_data.hpp:10,
from ./boost/thread/thread_only.hpp:17,
from libs/thread/src/pthread/thread.cpp:11:
./boost/system/error_code.hpp:221:36: warning: 'boost::system::posix_category' defined but not used [-Wunused-variable]
static const error_category & posix_category = generic_category();
^
./boost/system/error_code.hpp:222:36: warning: 'boost::system::errno_ecat' defined but not used [-Wunused-variable]
static const error_category & errno_ecat = generic_category();
^
./boost/system/error_code.hpp:223:36: warning: 'boost::system::native_ecat' defined but not used [-Wunused-variable]
static const error_category & native_ecat = system_category();
^
:71:suffix or operands invalid for movq'
:72:suffix or operands invalid for
movq'
:75:suffix or operands invalid for `movq'
...failed gcc.compile.c++ bin.v2/libs/thread/build/gcc-5.4.0/release/link-static/threading-multi/pthread/thread.o...
...skipped libboost_thread-mt.a(clean) for lack of pthread/thread.o...
...skipped libboost_thread-mt.a for lack of pthread/thread.o...
...skipped libboost_thread-mt.a for lack of libboost_thread-mt.a...
...failed updating 3 targets...
...skipped 12 targets...
make: *** [/Users/yumm/zcash/depends/work/build/x86_64-apple-darwin14.3.0/boost/1_62_0-2b5cb9f1124/./.stamp_built] Error 1

What Mac OS version are you on? And what Xcode version do you have, @yumm?

Xcode Command Line Tools (xcode-select) version 2339
osx version 10.10.3

@yumm can you please paste the output of "brew config" and "brew env"?
Thanks

brew config
HOMEBREW_VERSION: 1.1.1
ORIGIN: https://github.com/Homebrew/brew
HEAD: edf042ee97f80955b077724119e717a51eb25e29
Last commit: 5 days ago
Core tap ORIGIN: https://github.com/Homebrew/homebrew-core
Core tap HEAD: 421ed9535fcb66f43f23e8eedd380b898abcab2d
Core tap last commit: 9 hours ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_REPOSITORY: /usr/local/Homebrew
HOMEBREW_CELLAR: /usr/local/Cellar
HOMEBREW_BOTTLE_DOMAIN: https://homebrew.bintray.com
CPU: octa-core 64-bit haswell
Homebrew Ruby: 2.0.0-p481
Clang: 5.1 build 503
Git: 1.8.5.2 => /Applications/Xcode.app/Contents/Developer/usr/bin/git
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby
Java: 1.6.0_65-b14-466.1
macOS: 10.10.3-x86_64
Xcode: 5.1.1
CLT: 7.2.0.0.1.1447826929
X11: 2.7.7 => /opt/X11


brew --env
HOMEBREW_CC: clang
HOMEBREW_CXX: clang++
MAKEFLAGS: -j8
CMAKE_PREFIX_PATH: /usr/local
CMAKE_INCLUDE_PATH: /usr/include/libxml2:/System/Library/Frameworks/OpenGL.framework/Versions/Current/Headers
CMAKE_LIBRARY_PATH: /System/Library/Frameworks/OpenGL.framework/Versions/Current/Libraries
PKG_CONFIG_LIBDIR: /usr/lib/pkgconfig:/usr/local/Homebrew/Library/Homebrew/os/mac/pkgconfig/10.10
ACLOCAL_PATH: /usr/local/share/aclocal
PATH: /usr/local/Homebrew/Library/Homebrew/shims/super:/usr/bin:/bin:/usr/sbin:/sbin